Download on LAN is extremely slow, Upload is normal

Hi,
I would like to start with Thank you for everyone who will assist me with this issue.

I setup my EX2 Ultra few months back and configured by my PC to backup on it. The upload was nice and even right it is working fine. I just tested it again and I can backup without any issue. However, when I try to retrieve the file back to my PC, I am getting extremely slow download speed with errors that stops the copy process.

My Router is Linksys AC1750 along with Bitdefender Box for security. All the devices i.e. my PC on LAN, router, security device and WD Cloud are connected with 1GB LAN connection.

Following is my troublehsooting

  1. Access file with normal setup but extremely poor transfer rate and errors
  2. Disconnected security device but same transfer issue
  3. Tried from a laptop on wireless same performance
  4. Restarted my PC, router and Cloud; still same performance
  5. Tried to download those files from files.mycloud.com and there was NO ISSUE, got 12MBPS speed as I have 100 MbPS FIOS
    this makes me curious that how come the download over internet is working fine but not on LAN.

Any idea!

P.S. I am thinking to reset and reconfigure my network to clear any bottleneck, if any!

Hi aqilfaiz,

You can try few more steps given in the link below.

You can contact WD Support team about this from the links given below.

To Contact WD for Technical Support


The link below will allow you to call support.

Hi-.

I got a hint for you.
Please, uncheck the ‘jumbo frame’ if you can. This is in the LAN router’s configuration.
In my case, I know that the ‘jumbo frame’ has a troble with ‘Mycloud ex2 Ultra’.
You should uncheck jumbo frame in ‘Mycloud ex2 Ultra’.
So, If you can disabling the function then you may feel that all is very fine.

CUL~.

Thank you very much guys for your suggestion. I reset My Cloud through the reset button on the back of the device and that fixed the problem.
Not sure yet that what could have been the problem. No. of connections may be, which were around 5 to 6 may be and I checked the activity on the device which was mostly zero. But anyhow.
Thank you very much once again.