Don't know the model, but it's quit on me


#1

I’ve had my WD external harddrive for about  year, and I’ve lost the box.  I looked at the model number on the device itself, but when I looked up that number it didn’t look like the same thing.  The closest thing I saw was something that was simply called My Book Essentials.  Anyway, if more specific information is needed I can do some more investigating, but I have a feeling somebody is going to simply tell me it’s broken, so I won’t waste my time with that.

Anyway, the thing has been working fine for me going on a year.  I only have the thing about halfway full, and it’s mostly with my iTunes library and some photos, plus a few other files.  The first trouble I saw out of it was a couple days ago, I had been listening to some music, but when I selected another song I suddenly heard this loud clicking noise coming from the drive.  After a few seconds it stopped and the song started playing.  But having not liked the sound of it I turned off my machine and unplugged the drive.  Thinking it might be going out on me I decided it might be best to leave it alone until I could get something to do a complete backup on.

However the next day I needed to get a file I had saved on it, so I turned off my machine, plugged the drive in, started up the computer, and while I did get a few clicks as it started up, I had no problems with it.  I even played the same song that had caused the problem before and didn’t get a sound.  So I chalked it up to being a weird quirk, and just left it plugged in, but still planned to back it up.  Later on though it started clicking loudly, even though I wasn’t accessing anything off of it.  So I shut down and disconnected again.  But when I got my stuff together to back it up, I turned it on it’s like it’s not even there.  The drive lights up and clicks when it starts up, but other than that it’s just a paperweight.  It’s not recognized under my computer, in device manager, or anywhere.

I haven’t made any updates to my computer lately, so nothing has changed since when it worked fine and when it stopped working.  I’ve tried connecting it to a different computer, and it wasn’t recognized there either.  I’ve used a different USB cable and no dice there either.  I’ve read in some discussions that it could be a power issue, that some USB cables don’t give it enough power, but mine has a seperate power supply that plugs into a socket.    I’ve read several other things to try, but they seem too involved or potentially dangerous.  I don’t want to stick the thing in my freezer, and I don’t know how to take the thing apart and install it into my machine. 

I don’t know much about these things, but  think there is something other than it being simply broken, or the disc corrupted.  It’s getting power and lights up.  And I don’t get some message saying the disk cannot be read or it’s corrupt, when I disconnect the USB and put it back in, it’s like I didn’t even do it.  There’s not that little sound that denotes a USB device has been plugged in, working or not.  I don’t know though, any help would be appreciated.  I bought this thing thinking they were pretty sturdy, most of what I have on there isn’t backed up, because I thought that WAS my backup, so I will be losing a lot of stuff there.  I know that’s my fault for obviously over-estimating the sturdiness of these things, because while researching my problem it sounds like external harddrives are even more prone to breaking down than computers themselves.


#2

I have the same problem only mine is only 4 months old.  It worked then to back up my data (or at least I think it did).  It sat in the box it came in (no one touched it) and now I’m trying to retrived my backed up info and it won’t appear on my computer.  The box has lights like yours-but nothing.  Talked to the tech today, but lost connection with him and will have to try again tomorrow.


#3

Brownie2112

Clicking can mean one of two things: the drive is definitely dead, or it’s not getting enough power.  Try plugging it directly into the wall.  Don’t leave it that way, because it can get hit with a surge, but just to see if it starts spinning and is recognized.  If it doesn’t show up, then you’re left with data recovery.


#4

It must just be dead then.  Because I plugged it directly into the socket and still just got a clicking sound and it’s still not showing up anywhere.  Man, that’s harsh.  I really can’t afford data recovery.  I could barely afford the external harddrive when I bought it, but at the time having recently had a computer crash and losing all my data I figured it was a sound investment.  I guess not.


#5

Dear Brownie.

My two MyBooks died. I extracted the disks and they are 100% ok. See here: http://bit.ly/mybookstinks

Cheers,

  • c.a.t.

#6

cteixeira, I’m not sure I uderstand.  That link shows you how to open the whole thing up and take the drive out, but what then?  Should I try to install it in my machine, put the whole thing together?