Dolby digital audio issues with .iso

The audio for the first track on a DVD or Blu-ray on a a network share does not play if it is “dolby digital”. (I have not tried playback from a local drive). The audio for all other tracks (including “dolby digital”) work. Switching back to track 1 again and the audio stops working. All other audio formats are working properly.

  • Firmware: 2.01.86

  • What happened: For .ISO files (both BD & DVD) If Audio track 1 is “Dolby Digital” it will not play. All other tracks (including Dolby Digital tracks) will work.

  • What are you doing: Trying to play an .ISO

  • Does this happen every time: Yes

  • What hardware and media were you using: I was using a WD TV Live streaming an .ISO from a Synology 1513+ via SMB share

  • Did this happen with previous firmware: No

  • Does power cycling the unit solve this: No

  • Does resetting the factory defaults solve this: No (it was annoying that I had to do this and reset all my settings)

  • Have you tried this on other devices: Yes. I set up a XBMC mini-computer to test streaming .ISO files. It worked (but the box is old and slow).

I know it doesn’t help you any, but I had the exact same issue on my SMP recently.  In my case, a full power-off of the unit cured it.  When you say you power-cycled the unit, did you do a full power off (hold down power button on remote for at least 5 seconds)?  Or alternatively disconnecting power for a minute or so.

Actually, it works just fine on DVDs and BDs with 2.01.86 over network shares here.

I have tried unplugging and resetting. I am going to try and reload the firmware and see what happens.

I converted the .iso to .mkv and it work properly.