Does anybody have success with playon?

I am trying to get it working but it always quits after 15 minutes. if anyone here has success, plesae let me know what your WD firmware version is and anything s[ecial you had to do.


Hi there, if I were you I’d try the “search” option on the forum so you can look for all the threads related to the PlayOn media server.

Good luck!

I’ve been using PlayOn since spring of last year; using all the versions that have come since then.

There was a period of time last Fall where WD broke it, but it was fixed later.

I have looked here but the seachign isn’t that great and most of the posts are old and don’t realate to my problem. if I google it I cannot not get results for PlayOn I gets results for Play on (separated).

I am having problems with the shows playing but then dropping after 15 minutes - every time on every channel. Plus if I even open a browser, the stream starts shuttering.

I have been going back and forth with playon tech support (who are really fast at helping me) and they have said that their diagnostics are showing that the stream is only at 3.5mb which explains the drops and stuttering and also  points at the router as the bottleneck. So that’s where I am heading next since I can confirm that my general download speed is 12+mb. I have a d-link DIR-655 that I bought becuase WD recommended it. And it’s connected via ethernet not wireless.

That’s odd. I have a dlink dir 655 and am using Playon and a Live Plus. No drops or stutters at all. I’ve been using it this way for about 3 months now. With both devices wired, 3.5 mbps seems extremely slow when you are using a gigabit router. Are the cables between the computer running playon and the router, and the router to the WD TV Live ok? Any kinks or the cable or anything?  How is your speed out to the internet? What does show your download speed at? It might even be good to run that test while connected to your router and then again with your PC bypassing the router.

Thanks for your reply. Glad to hear you have a similar setup as mine and it is wokring fine.

My speeds downloading are at 12+ via DLSERPORTS as well as my news reader (while I download). I have been in the d-link forums and there are some things that I am going to try tweaking tonight.

Did your setup work right out of the 655-box? Do you know if you have things like QoS turned on or off? How about mulitcast streaming. And do you have reserved IP addresses for the devices hooked up on your pc? These are all questions they asked me this morning. I am new to this kind of network setup so I have no idea - I think I just did the automatic setup.

I admit I work in the I.T. world and do tend to customize things. The slow speeds might have something to do with the MTU that is set on the router. You can see if you can move it up a little (I think it defaults to 1400, try 1500 or 1600).  I had been running the 655 for about 8 months before buying a WD TV box, so it is hard to say what would have worked out of the box. Anyway, I have QoS off (I don’t use voip phones or anything), I think multicast streaming is off (don’t have the router in front of me), and I do use reserved IP addresses in my dhcp configuration. Be interesting to see if you have jumbo frames enabled on the router too. If so, turn it off.

1 Like

don’t know what MTU is but I ran speed test and I had a download speed of 20+mbps.

from the d-link forum, I followed suggestions and assigned IP addresses, turned off QOS and checked mulitcast streaming, which was unchecked and I left it unchecked because I was not sure if it should be checked or unchecked)

where do I find jumbo frames?

No, no no.   You can’t run JUMBOFRAMES.   

no idea what jumboframes are but the other tweaks seem to have fixed the problem. I watchd two episodes of the daily show wihtout any disconnect and I was puttering around the internet while it was streaming and had no stuttering wehich is also great.

thanks for your help!

As I and TOny said, jumboframes are not good anyway, so don’t worry about them. Sounds like maybe your QoS rules were interfering. Glad to hear things are working.