DO NOT UPGRADE TO OS5 you lose ALL app support

I’ve had my WD myCloud gen 2 for few years. On the box it said it supported transmission which is why I bought it. Transmission has never worked through following WD’s apps or support. Eventually, found this community. Where the users bypassed WD’s soft restrictions on being able to manually install apps and was then able to install transmission.

I naively upgraded to OS 5 thinking they added more functionality to the myCloud. No. You lose all app access. And from further reading they were specifically targeting transmission.

So this is my PSA – do not upgrade to OS 5 and if you’re thinking about buying a myCloud or any other NAS from WD look else where as they do not live up to their on the box marketing. What am i supposed to do wait another few years to get transmission to work again?

The best anyone who has bought the myCloud devices can do is stay on OS3 and follow fox and other’s instructions. Some people on here are actively trying expand the functionality of the myCloud – WD is not. WD is actively trying to take away functionality which they already claimed to support when we bought it.

I don’t know how everyone else values their time but it’s one of the few resources I can control and I am willing to pay a lot more money just not to use WDs NAS anymore.

Have you tried using the OS3 procedure to install unofficial apps on the gen 2 running OS5 to get Transmission reinstalled?

It should be noted that not everyone needs or wants unofficial “app support” or wants to install unofficial mods to their single bay My Cloud. So while you may not want OS5 on your Gen 2 because your running unofficial mods, other folks may want to install OS5, assuming there are no other major issues with it.

For anyone interested WD has an OS5 compatability matrix that shows which “apps” the gen 2 single bay supports:

Yes I have tried manually installing OS3 apps. The error message is “this is an OS3 app and is not compatible with OS5”.

Also, SSH has been altered and I can no longer SSH into the nas.

This graphic released by WD shows more clearly what you are losing compared to with OS3 to OS5. As you can see there are virtually no apps.

You also might want to chekc out this if you use transmission as they were clearly targeting its use in this update.

Thanks for update and quick reply. I’ll be sure to keep an eye on this thread. Looking for the same issue.

visit official site

Also, its fairly straightforward and riskless to go back to OS3 if you want to check it out. The most complicated thing was figuring out how to use telnet.

Don’t have an gen 2 running OS5 so cannot confirm.

I would like to confirm that Western Digital has made the process of installing third party very easy. All the apps that are available for My Cloud Mirror, My Cloud EX2 Ultra etc. Can be installed on the My Cloud Gen2 after you compile them for the My Cloud Gen 2 OS5. After that you just click the: “Install an app manually” from the App Store and you’re done.

And on another difference between OS3 and OS5 that some may want to be aware of before upgrading. It appears one can no longer manually set the remote access/cloud access ports. Instead, per WD Staff, the cloud access ports are managed via UPnP. Some may have UPnP disabled within their router. Something to be aware of.

My Cloud OS 3 Remote Access used the following ports and allowed the user to manually configure port forward on the device itself.

Internal HTTP	80
Internal HTTPS	443

External HTTP	9000 - 9999
External HTTPS	9000 - 9999

My Cloud OS 5 only uses HTTPS and does not allow the user to manually configure port forward on the device itself.
OS 5 depends on UPnP to manage the forwarding of the ports.

Internal HTTPS	4430
External HTTPS  40000 - 49999

Until I see bin files for installing apps, I won’t get too excited.

Might as well cross post a reply in the OS5 section on this issue.

Well first you will need to Download this archive from this link:

You will need a Linux Distro (Ubuntu for example) use a big usb stick 16 or 32 GB
copy the file above on the stick or download it after you boot in Linux from the USB Stick
extract the files from the archive on the Linux desktop and don’t change the folder name ( WDMyCloud_NAS_Apps_GPL_20201112 ) that way it will be easy to just copy the commands and only type you’re user name where you have {Your User Name}. You can also use a virtual machine to install linux. I’ve used Ubuntu on virtual machine.

In the archive you have a basic instructions set made for you by WD on what to do, the example they give is for the Transmission App (WDMyCloud_NAS_Apps_GPL_ReleaseNote.txt).

This is a detailed step by step on how create the Transmission App because the release notes from WD are not that detailed if you’re not great with Linux:

Open Terminal and type these commands (Remember your Password and User Name after you finish installing Linux on the virtual machine or USB stick):

sudo -s

To Install Docker use:

cd /home/{Your User Name}/Desktop/WDMyCloud_NAS_Apps_GPL_20201112/dockerfile/

then type:

sudo snap install docker


sudo apt install

wait for it to finish

then type:

docker build -t gza_build_env .

wait for it to finish.


cd /home/{Your User Name}/Desktop/WDMyCloud_NAS_Apps_GPL_20201112/Apps/

type this to display the supported modules

’/home/{Your User Name}/Desktop/WDMyCloud_NAS_Apps_GPL_20201112/Apps/MyCloudOS5_mksapkg’

You should see this:

Supported model_name:

then change folders by typing:

cd armhf


cd Transmission

this last command will create the app in the armhf folder for the My Cloud Gen 2 it is a bin file but after the bin extension it will have date like this: WDMyCloud_Transmission_1.09.bin(02092021) you can delete the date after .bin or just use it like it is:

…/…/MyCloudOS5_mksapkg -E -s -m WDMyCloud

for a another app just type:

cd …

and change the folder for example

cd AmazonS3


…/…/MyCloudOS5_mksapkg -E -s -m WDMyCloud

and you will have the AmazonS3 app for My Cloud Gen 2

I hope this helps everybody. If you have any problems I will do my best to help.