Do I need to format HDD before inserting? A HDD replacing nightmare

You guys are my only hope…

So one HDD in my WD My Book Live Duo 8TB failed.

The HDD is P/N 0F14697 and the model number is HDS5C4040ALE630.

I ordered a similar HDD but received a 0F14696 (the last digit is 6 instead of 7). The model number is exactly the same: HDS5C4040ALE630.

When I told the store that I received the wrong HDD, they told me that the model number is what counts . . .

Unfortunately, the WD My Book Live sees it as an unsupported HDD.

Is it really that specific? The model number and all of the HDD’s parameters are identical. Is there something I can do - like reformatting it to a specific file system or something - to make it work with the WD unit?

Any help will be greatly appreciated.

Thanks!

That model number corresponds to a Hitachi hard drive, not a WD hard drive. A factory WD My Book Live Duo should come with WD Green or WD Red hard drives, so your device is using a custom configuration that may not be supported by the unit’s OS.

The WD My Book Live Duo 8TB came with two HGST 0F14697 HDS5C4040ALE630 HDDs. It was brand new - ordered from Amazon with WD warranty - and needless to say, both worked in the device for over 2 years and the working HDD is still active and supported.

HGST is part of WD for awhile now.

While Hitachi has been a part of WD for awhile, the WD My Book Live Duo was on production before the acquisition. If the unit was completely new then this is an anomaly.

Maybe you should try contacting WD Support about this. You can do so over the phone or via E-mail.

I’m in touch with WD. I’ve spoken to WD support people. They told me that I need an identical HDD.

I then contacted HGST. They don’t sell HDDs directly and told me that it may be hard to find such a HDD - they don’t make them anymore . . .

I hoped that a HDD with the same exact specification, same model number and only the last digit in the P/N different, will work. It seems crazy that it is so specific. The WD support people couldn’t help me with that.

So I have an answer. According to WD support you must have the exact same HDD.

I’m extremely disappointed and will never buy or recommend WD again. I’ve had other NAS systems and never had such problems. The fact that you can’t replace a HDD with a similar one - even with the exact same model number is simply crazy.

Basically, WD NAS products only work until one HDD fails (because you can’t get a replacement HDD - they don’t make them anymore . . .) Terrible. And they admit it.

This is an official answer from WD: "Sadly, as both the My Book Live Duo and the Hitachi drive in there are end-of-life products, your best option would be to contact the place of purchase to replace the My Book as a whole and not just one drive."

So I bought an 8TB system and two years later it’s a nice looking brick. Thanks WD.

To my astonishment, my first 8TB DUO came with Hitachi HDDs, my second 8TB DUO came with WD Green and my third 8TB DUO came with WD Red.

I tried to rebuild a Green in a Red and it DID NOT WORK.

When they say you need EXACTLY the same drive they really mean EXACTLY the same drive.

According to the WD Knowledge Base Answer 8644, replacing a drive with a new drive that uses an identical model number to the drives included in the enclosure, should work.

I do have a HDD with an identical model number!

WD support told me to try to write zeros to the HDD using WD DataLife Guard tools. I did it. No go.

It is very strange. The NAS UI sees the new HDD - the model number is there (identical to the original one), serial number, and the self test passed. But it’s “unsupported” . . .

I did a Full Factory Restore. Still the same problem.

When I ssh the device and look at the HDDs I can see the problem: in ssh the model is “unknown” (md1 and md2), the partition table is “loop” and you can’t see the main 4TB partition.

So in the NAS UI the model number appears, when I ssh and use parted -1, the model is unknown.

Is there a way to format the HDD via ssh so it will be recognized by the device? Can I change the mode?

Is there a way to upload screenshots of the ssh to this forum?

Thanks!