DNS settings on My Passport Wireless Pro

#1

Having a problem when using the WD My Passport Wireless Pro (WD Pro) as a Plex Server and have the “Connect to Internet” turned OFF. The problem is, my devices (iPad, iPhone) connect to the WD WIFI and when they get their IP address (192.168.60.x) they get two DNS servers, 192.168.60.1 and 8.8.8.8. Well, 8.8.8.8 is Google DNS and with internet turned off, this will never happen and causes huge delays in software working when they attempt to resolve using 8.8.8.8.

With Internet turned off, shouldn’t DHCP just hand out 192.168.60.1, and when internet is turned on THEN hand out 192.168.60.1 and 8.8.8.8?

Is there a way to configure this? Currently, on my iPad and iPhone I can manually configure the DNS for the WD WIFI, but I have to manually add or remove 8.8.8.8 depending on if I am using internet or not.

I checked everywhere in the web config, and the WD Cloud app, but could not see how to configure DHCP or DNS settings.

#2

Hello lancorp,

You could try to setup the device using the information provided on the links below.