DNS Errors, can't stay connected or connect to the internet!

Wondering if anyone can help! Have had Hub for almost 2 years with a few minor issues .But really do  enjoy using the device,  so much that I thought it would be a great gift for the son in law. 

Installation of the new unit at his house  went as expected, but then after the final firmware update the internet connection was spotty and then stopped working. Error message said the DNS number is incorrect.  Downgraded back to the original  factory firmware and the internet worked just fine. Upgraded to the most recent firmware, and the internet would not work. 

So I bring the unit back to my place unplug my unit and hook up the new unit using the latest firmware and…tada…it worked perfectly.  I still need to get it working at his place, not sure what to do next.

Any help would be appreciated.

Did you do a factory reset on it, at the son-in-law’s house?  also, is his router using static or dynamic ip addressing?

YES, did the factory reset.  No luck. 

Not sure, but will check. I suspect the issue is with the Router. Going to install a new router, we will see.