DLNA Samsung TV


Have had the WD My Cloud 3Tb for five days now. Steadily and slowly uploaded a couple of hundred Gb of movies to it. However, my Samsung 8 Series TV does not seem to detect it, nor does it show up under Settings > Media > Media Streaming/View Media Players option. 

The main reason I bought this device was to stream over DLNA (this TV connects via DLNA to every other device I own and friends devices). Can anyone help with a solution?  (Obviously the TV is on the same wifi network as the My Cloud)

I am sure I am missing something. Would really appreciate a reply. I’d rather not have to return this otherwise lovely device. 


Not to state the obvious, but do you have Media Streaming turned on for the Share you have your videos in on the MyCloud.

Yes, I do - it is turned on and all the Shares also have media streaming turned on. 

The TV is detecting my laptop and mobile as usual and streaming perfectly, but does not show the My Cloud. 

Under the View Media Players in the My cloud interface, no devices are listed. 

I have logged in to the Twonky Media server and under Sharing the My Cloud only displays the IP address of my laptop. It does not show the TV up. 

Please help!

Sorry can’t  be more helpful other than to tell you my 6 series sees it fine…and I didn’t have to go into any fancy settings.

Have you tried adding the device manually from the dashboard…so it generates a code?

I suggest you check the status of the twonky server (http://<wd_IP>:9000). Initially, I had about 400 GB worth of media between music, home videos, movies and pictures and some times the twonky server would crash when scanning. Because I only need DLNA for movies, I changed the path to scan and what to scan for via its web application. Unfortunately, the settings reset to default whenever it’s restarted but I can live with that.

If you’re looking to use DLNA just for movies, it’s great. However, if you’re looking to have all your media via DLNA depending on your library size you may encounter performance issues. This is from my own experience.

Thanks for your reply. I haven’t tried adding the TV manually yet (I’ll do that tonight) - though I assumed if you added a device manually it meant you get an activation code which is then typed into an app on the device (e.g. this is how I added my mobile). I haven’t heard that there’s an app for the My Cloud on Samsung TV’s… am I wrong?

Also, can I ask which year your TV set is from? Mine is a UE46D8000 from 2011 and thus far it picks up all my mobiles, laptop and other devices fine on the AllShare/DLNA settings - it just doesn’t seem to spot the My Cloud. Could it be that they are running different and incompatible versions of DLNA? Or is that not possible (I’m a novice re: DLNA)

Also for the poster below you, I have checked and refreshed the Devices list under Sharing in the Twonky Media Server settings for the My Cloud and it still only shows my laptop with the correct IP and Mac address and not the TV… Any other thoughts?

Many thanks to all replying so far

Hi guys, 

I am still unable to see the My Cloud device on my Samsung TV (8 series) though the TV detects and streams from my laptop and TV on the network. 

The My Cloud has updated itself to the latest firmware and will stream movies etc directly to my laptop without any lag, similarly to my mobile. 

I’ve checked for the TV under the Twonky Media Server Sharing settings and it does not show up. I think only my laptop is showing up as a generic media receiver. 

Please can someone advise? I’m really feeling quite down as a result of this. 

Many thanks,

http://forum.qnap.com/viewtopic.php?f=177&t=77167 (similar but no resolution)

Have you got an android smartphone? If you have you can install skifta from the play store. (free)


You can use this to see if your MyCloud is working correctly regarding the DLNA server.

If its working you should be able to select the Mycloud and then play your media (if supported) on your phone.

This is a troubleshooting test to see if another DLNA device can actually see the MyCloud and stream from it.

Thanks very much for your efforts Rich. Much appreciated. 

Just to say, after a lot of fiddling around on the internet and trying this and that, I ended up installing Serviio on my laptop and using that to share the path to the My Cloud, so that my TV can play all the files on the Cloud now. The only (minor) downside is that my laptop needs to be on in order to stream via Serviio to the TV. 

I am sure there’s a way around this - I just can’t figure it out yet. Would be grateful for any more advice. 

I’ll go and look at the links you’ve sent me now Rich. 

Many thanks,

Hi Guys

Sorry to be jumping in this thread but I was also having a similar kind of issue although not identical! The details of my issue are described below - any pointers/assistance shall be highly valued.

ftmb2 - What idid you eventually do to get it going?

I was also having a similar issue with my Panasonic TV’s (supposed to be DLNA certiified - model Nos. for them are TH-P50VT20A and TH-P42V20A). This was when I was trying FreeNAS on a spare PC. All my devices were able to see the FreeNAS ‘Share’ but my TV’s. I have now given up on FreeNAS and am seriously considering buying WD My Cloud (Personal) NAS. I just wanted to make sure that it would be visible to my TV before I bought it. I really don’t care if it is not visible to any of my other devices such as mobiles/tablet etc. - it must be visible to my TV’s though.

Just so that I provide you all the most relevant information to help you all to help me, this is the arrangement that i currently have :-

I have 1 modem router (in my study) and 4 switches at various places in the house.

The 2 TV’s are connected to 2 different switches in different rooms

I did try Serviio - this was installed on a Windows XP SP3 PC connected to switch other than the switch that either of the TV’s are connected to - but for some reason my TV’s didn’t see the Serviio media server. It was suggested that I should connect this PC to the same switch that the TV’s are connected to - but that wasn’t possible and the TV’s are on different floors.

Questions :-

Do I necessarily need to connect the WD My Cloud NAS to the modem router or can it be connected to a switch without  any impact?

Is any special setting required (either on the TV or this NAS drive for it to become visible to my TV’s? I couldn’t find any settings on my TV for this!

Where do installing Twonky come in to play here - doesn’t this NAS drive come with the required media software installed on it?

Best regards


Hi guys,

I had the same issue but i managed to “solve it” this way:

I have access via the Samsung “smart hub” menu of my TV to “Samsung link” from which I can stream from my WD My cloud.

I hope this helps. Let me know.

Merry Xmas.