DLNA problems (Plex)

Recently I’ve started to use my new WD MyCloud Home NAS with Plex installed. And got immediately in trouble. All photos from my DSLR camera are shown really small sized on my new Samsung Smart TV. All of these photos are JPEG files with resolution approx. about 4000x3000 pixels and 6-10MB of size.

When I use my Samsung TV to view photos from NAS, all photos are small in size in the middle of the screen and when I display file information on my TV, photo dimensions are way smaller then the physical file on NAS really is.

I’ve tried to copy all the same photos on USB storage and view them on my TV again - everything works full screen in high resolution. So this definitely is a Plex related issue. I assume there is some kind of optimalization setting or so which tends to scale photos to lower resolution and that’s causing the problem.

I’ve tried to browse settings of Plex and changed some of them, but no success on solving the issue.

I also tried to copy all these files to my older Mybook Live NAS and everything works there without any problems (there is no Plex, but Twonky Media server).

Plex version: 3.57.1
WD MyCloud Home SW version: 5.0.3-103

This is Plex related issue for sure, I’ve also tried to describe this issue in Plex forums (as there is no direct contact for technical support for Plex) but without any response. Result is that I’ve purchased new WD solution after being satisfied with two previous NAS from WD for my purposes and now this seems to be a very bad experience so far as I cannot use it as I’ve been used to.

Also I’d like to ask if there’s any other option than Plex for DLNA streaming with My Cloud Home?

Any ideas on how to solve this issue please?

Many thanks

IMG_1778