DLNA Media Server Does Not Scan Media on MyCloud 4TB after Firmware Upgrade

I’ve been running WD MyCloud 4TB on my network for many months without issue. 

However, when I upgraded my firmware to v04.00.00-607, the device’s DLNA media server can no longer scan my media. Additionally, I cannot stream media as a result. 

I rebooted the device and my router, but the problem persists. 

Any ideas on how to fix? 


Go into the share configuration for each share via the GUI.   Turn media streaming OFF, then turn it back on again (for the shares you want enabled.)

I am on a MyCloud 2TB with latest v04.00.01-623 firmware and have the same problem. Tried the suggested “turn Off/On” media sharing on desired share, but still no media files in DLNA server list (the media database,on the other hand is OK). Any other suggestions?

This may be too late for you now but I have only just bought a unit but it may be of use if anyone else experiences the same problem.

I had the issue when I set mine up (firmware v04.01.02-417)  ie. “no media files in DLNA server list (the media database,on the other hand is OK)” so the dashboard knew the content was there.

I managed to resolve it by accessing the twonky server using a browser (address http://ipaddress:9000 not mycloud:9000 as this didn’t work for me) and going to the “sharing” section. The share was shown as “/Public” so I hit the browse button and remapped the share and it showed up as “/shares/Public”, other folder I manually typed “/shares” in front

Once this was done it went off and found the content that I had on the drive and listed it in the DLNA Media Server section, I also did do a rescan just to be sure.

Hope this helps someone before they get as frustrated as I’ve been !!