DLNA issue on WD MyCloud Mirror Gen 2

Hello,
I have 8T MyCloud Mirror Gen 2 (run at RAID 1 =>4T) . I have 1 SS Galaxy S6, 1 SS Galaxy Note 5. I install WD App on them to make auto backup all pictures and videos. Everythings worked well but after some firmware updates (maybe from August) , it has problem.
I have 2 Samsung DLNA TVs , 2 Sony TV with Androibox. Now: 2 Samsung TVs can see only which had been auto backup before (maybe before August) ; 2 Sony TV with android box can see all before and some after that but not all. DLNA apps on SS Note 5 or S6 example Kodi or Bubble DLNA have issue same with 2 Sony TVs.

How i fix it ?

Hi, have you tried resetting the My Cloud? Have you tried recreating the access for those devices?

Hi. I’d tried resetting the My Cloud Mirror about 10 times. I cleared and recreateed all profile/account of those devices too. May there is issue about permission ?!

If you have performed a reset on the My Cloud drive, then the permissions should have being fixed. What version of the firmware you have in the drive?

Have you re-scanned the NAS’s DLNA database found in Settings/Media? Do this first, then Kodi allows you to refresh its database, and perhaps your other items/devices permit theirs to be refreshed, too.

It’s the lasted firmware version . I have performed reset, rebuild database … The isuse is still there. It just affect on the medias which are auto backup from mobile after ~ 15-Sep.

I found that the issue is mp4 file. At ~15/09 I start using another mobile phone : Galaxy S6 and Galaxy Note 5. These phones record video in mp4 format which Twonsky recognize as audio. So, can’t found them in video.
So, how to fix it?

i have the same problem and no solution…so far. haven’t tried handbrake, but already tried renaming and this My video file recognized as music?