DLNA Database updates breaks my PS3 visibility

I have had ongoing issues with my Duo 6TB version.  I did post in the firmare update thread but got no feedback so this is a last ditch attempt to resolve before returning it.

Problem: Drive shows up on my Mac and Windows 7 laptop and I can read/write/stream to them but does not show up on my PS3 or Xbox.

  • Media streaming is enabled in the Duo’s UI and shows the PS3’s ip and lists it as a generic media server.
  • A rescan of the media is ongoing (days) and still only shows at 8 video files no pics, no music.
  • I currently have 400+ videos, 9000+ photos and 4000+ music tracks on the Duo.
  • All have been placed in the ‘pre-setup’ public shares, no new shares have been created.
  • I am using Raid1 format.
  • The latest firmware has been applied to the Duo.
  • I can access all files from the WD 2go app on my Ipad (works very well) and all pic’s from the WD photo app on my android phone which both appear to work locally and via the internet.
  • PS3 has ‘Media Server Connection’ Enabled in network settings.
  • PS3 is hard-wired to my router as is the Duo.
  • The Duo is seen on the PS3 after a rescan of the media servers on the Duo (and PS3) but is not accessible.  It then disappears shortly after.
  • SmartWare on my windows laptop only shows the Duo intermittently.

So the two reasons why I bought this was to stream video to my PS3/XBOX and backup data from laptops.  As it can currently do neither the device is useless to me.  I have spent the best part of 8 days trying to resolve this and have seen many others post with similar issues and as yet no real fixes.

After my initial post I had considered doing a factory reset but on reflection opted just to erase most of the data I had put on the drive before trying this.  After leaving myself with 1 video, 2 music tracks and 32 photos I ran a re-scan and for the first time the server status tab on the GUI reported the same.  I switched on my PS3 and the drive had appeared and I could access all the media without any issues.  I proceeded to add media (10’s at a time) of video, then music etc and re-scanned.  The status updated as expected and access to the media through the PS3, Mac and laptop had no issues, speed was good and streaming multiple media to multiple devices had no problems.

500 video’s later things were not so good.  The re-scan stopped updating the dlna database status page and the spinny re-scan symbol remained.  Also at this time the Duo was no longer seen on the PS3.  I deleted the batch of video’s which I had suspected broke the re-scan database status update and re-scanned but this time the counts were completely reset.  I removed a few more and re-scanned but still no change.  I dont think I can stomach starting from the beginning again only to end up in the same situation.

With these symptoms can anyone offer a suggestion to the problem, as a fix appears to be impossible to come by?

Thanks in advance.

Hi Storm3D

Think I saw similar problems from  jamesmccosh

Same here too… largely vanilla setup and new firmware; just wanted get some video running on the PS3. OSX laptop is fine.

Seems my first NAS purchase was an expensive mistake!

I have seen similar problem on my MBLD 6Tb, but I would describe as the NAS is available for file sharing, but the DLNA media server goes offline (not visible to DLNA clients like PS3 and Samsung Bluray). Only thing that works for me is a reboot of the MBLD. When visible, it works well, but better from PS3 than other players, and also better off same switch/router. Luckily I have older MBL 2Tb with Twonky media server to compare. That is very stable, and hardly ever disappears. But the MBL was similar and improved with each firmware update. I have Netgear N600 gigabit router and Bluray & PC attached to Netgear GS608 gigabit Switch.