DLGDIAG causes external USB drive to disconnect


I’m trying to investigate the condition of a WD 320GB laptop drive for someone. I’ve removed the drive from their laptop and placed it in a docking station which connects via USB to my own Windows 10 laptop. It is recognised and drive letters are assigned to partitions.

I’ve downloaded and installed Data Lifeguard Diagnostic for Windows (DLGDIAG 1.37.0) but when I run it (as Administrator) it detects drives and briefly I can see this drive’s partitions in the logical drive window but it never shows in the upper physical drive window. Almost immediately, I hear the Windows usb disconnect sound and the partitions disappear from logical drive window. Then I hear the Windows usb connect sound but also get a Windows warning message saying ‘USB device not recognized. The last USB device you connected to this computer malfunctioned and Windows did not recognize it’.
So now there are no drive letters assigned and it doesn’t appear as a USB device that can be ejected. All I can do is cut power to the docking station which prompts the Windows disconnect sound again. Finally I remove the USB lead.

I’ve tried a few times with the same result everytime.

Any suggestions how I can get around this to use DLGDIAG on this drive?


Edit: Looking in Device Manager, after the Windows warning message I mentioned, I see I have an 'Unknown USB Device (Device Descriptor Request Failed). Looking at it’s properties shows ‘Windows has stopped this device because it has reported problems (Code 43). A request for the USB device descriptor failed’


Found a hard drive caddy to try the disk with and problem’s resolved. Running extended test as I type. (Noticed SMART status is ‘Not Available’.)