DL4100 isolated from Internet

#1

I have a DL4100 with 4 4tb drives arranged in a mirrored array (a 10, I believe). It’s worked flawlessly since I got it several years ago. I recently moved out of the city where I had a fiber connection to the internet to a country location where my internet connectivity is provided by an ellipsis (Verizon) jetpack mifi.

I didn’t really care if the NAS was accessible away from the house, so I hung it off a Linksys WIFI router so that I could address it and connect to it from the house wirelessly. That worked for about 2 weeks.

This morning I tried to get into my photo archive on the NAS. It just hung. I walked into the room where the unit sits and pressed the up and down buttons next to the LED screen (which was just showing the device name) and it wouldn’t scroll through the panels. Since I couldn’t access the thing from the computer or get the screen to move, I held the power button down till it shut off, waited a minute and rebooted. I got the flashing blue light and a blank LED display. I left it for about an hour with the fans running. Finally rebooted it a second time using the poer button, same results. Tried resetting, same results.

All of that to ask this question… Is this a result of it not being accessible to the internet or is it a more local hardware issue?

Thanks

#2

The DL4100 should work without an Internet connection. There is even an option to stop the WD cloud service. I know it may not seem like something to check, but I assume you’re still using the original PSU? Is the PSU working correctly? Is it providing the correct voltage and power to the DL4100? Worth checking things from the ground up.

I had an old ICL OPD that started to badly malfunction on start-up or soon after start-up. I managed to get someone with electronics knowledge to change a capacitor on the PSU and from there on it worked.

With the PSU that is supplied with the WD is sealed, like all external PSUs. You don’t need to get WD’s PSU. Just one with the a compatible circular connector, correct voltage and sufficient output power. I’ll check later, but I got an Acer laptop replacement PSU which works perfectly on the DL4100 as a spare.

#3

Thanks Myron. I haven’t checked my PSU yet. I’ve a limited amount of real electronics background, but I have a couple of friends that are proficient.

The unit will work without the internet connection, but functionality is limited. You can’t add device accessibility without it, or at least I haven’t been able to and WD Support told me I had to connect it to the internet to do so. I was attempting to hook up a pair of Samsung S8’s for back up when I ran into that roadblock. I honestly could care less about any updates that would come along for the unit. It just needs to be functional on my home network. Not sure why any mfg would make these so they can’t be updated as a stand a lone. Today’s Web climate where everyone steals everything makes one take extra precautions and leave things unaccessible, not just security protected.

I foresee a new unit of sometype in my future. I had just backed up (copied) all the data to an external USB on Friday. Guess that was good timing. I hadn’t been on the unit since. Even with that, I’m not really looking forward to wiping those drives to start over.

#4

Right… You can add remote accessibility with the WD Cloud services turned off, but there is more of a technical set-up and it’s sort of normal. For example, you could configure the DL4100’s FTP server and configure the router’s port forwarding appropriately then use an FTP client on the remote device. I think you can still configure the DL4100 to have remote access to the NAS’s dashboard even with the WD Cloud services disabled. Updates can be applied manually by downloading any available update from WD and then using the manual update facility on the DL4100.

Not sure about the WD store, but there is no harm to enable WD services, install your app and disable WD cloud services.

The DL4100 should ba accessible on your home network by FTP, SAMBA service, iTunes and the built-in Twonky DLNA service with the NAS not connected to the Internet. Seems like a normal situation for a NAS in an off-line configuration.

Does that make any sense? As to the PSU assumption, it’s from experience. I wasted nearly a month with this ICL OPD machine before I realised that the only thing I had not checked was the PSU. For whatever electrical reason when the PSU was asked to deliver more power it then failed at that point. Gone are the days of simple transformers to these mode switching and power conditioning PSU that today’s electronics require.

I’ll try remember to details of the ASUS PSU I got as a back-up, but it can provide additional power to if the NAS ever needed.

I vaguely recall somewhere else on this community some dialogue about the supplied PSU causing some issues because of the upper limit of amps/watts it could supply to the NAS. Not sure about that.

Another issue I’ve noted is that there may be the slight possibility that one or more fd the drives may not be seated properly in a bay’s SATA connector? I has this issue with an early revision of the DL4100 and the solution I came-up with I’ve personally accepted as permanent

DIY%20rubber%20stopper%20spacers%20(Small)

I thought that may be worth a mention as you’ve had your DL4100 for a number of years. I used a bit of thin cardboard and double-sided sticky tape to make the stoppers about a millimetre taller. My low tech solution just made sure that the drives are fully seated in the SATA connector inside the DL4100 and remain fully seated in the connector.

#5

By chance, I pulled out the PS to an old CyberpowerPC laptop I have that is Asus based. It was the same specs but with a little longer barrel on the output end. It fit right in, but I got the same results so I’m going to assume this isn’t a PS problem.

I’m leaning towards a directory or structure problem with the raid array. I read a couple other threads where people were able to rescue the drives on a Ubuntu platform. I’ll double check my copies to make sure they are good. If so, I will probably forego a rescue attempt and look for a new box to install the drives in and reuse them. Not sure the replacement solution will be WD.