DL2100 - Undefined error during device setup

I’m trying to set up my DL2100 for the first time and I can’t set an email address for the admin account. I can set the First and Last name, but not the email address. When I enter it and confirm it, I get an error message with no description whatsoever other than “undefined”.

I tried the 40-second reset already, but I get the same error.

I also tried completing the setup process without setting an email address: I can get to the dashboard just fine, but if I try to add an email address for the admin account I get the same “undefined” error.

I tried adding other users and the same error occurs: the user is created but the email address I enter doesn’t get saved.

I’m on Win7 and using Chrome V.51

They “upgraded” mycloud.com last week and it is having issues. Just have to wait I think

Thank you! I guess I’ll just have to wait till they fix it then. Hopefully soon…


pls be so kind to inform if your problem has been solved.

I have Wd my cloud and I got the same problem issues. I can not register my email to get access to my files from outside. I can not generate any code.

Thank you in advance

The issue has been resolved and everything is working fine for me now.

I am having the same problem and can’t even set up the Admin part. Every time i put in the Email address to create an account it just comes up with an error box saying undefined. Have tried the 40 sec reset and this has made no difference. On the verge of this being returned and getting a refund !

Ia have the same problem!!! Anyone has solved?? And how???

Hi… I already solved the problem…
At first, I did 40 seconds reset twice with no results… after that, I got into the panel configuration section go to Utilities, and made a complete restoration of fabric values… this were all night and after that I could solve the problem… I hope this can be useful

Hi , i have the same issue, did multiple 40 sec resets , and restored system only setting and still have the problem. any other solution ?

If nslookup returns “Unknown”, change your routers DNS server and reboot the MyCloud and PC (assuming my cloud and PC are using the same DNS servers as the router.

Hi Sbrown, this is what i get when i look up on Terminal on my mac.


The IP addresses are correct for wd2go.com and mycloud.com.
I noticed that your DNS server is your router instead of your ISP (External DNS Server)

What router are you using?
Does it support DNS Rebinding and NAT?

Without knowing all the details, and assuming that everything is DHCP, one solution could be to set the routers DNS server to something public such as Google., reboot the router, My Cloud and PC so they are all using an external DNS server.

You seem to indicate that using a home router is a bad idea. I think this is improper feedback.

Users who purchase your NAS products are home users and do use home routers that handle DHCP for them. It just works.

Only Business class DHCP servers allow you to specify the DNS server and your NAS units are not suitable for Business use.

If he is properly resolving wd2go then that is not his issue is it? So what would he gain by changing his DNS Server to something else?

Do you have any feedback as to how to fix his problem?

1 Like

@Gramps I’m just trying to help

not working!!!