Disassembling mycloud home


#22

Thank you I have a samba licence from the DNS product. I know it’s free but to have the most recent version you have to have a version that has been adjusted to run on that server. If the serial code is asked for then it might work.


#23

also 4pin uart is present but when i was poking it it was behaving in weird way. system would not boot if ground was connected and was not outputing anything with only rx and tx connected.
only when powered for a second i had to plug gnd and then i got some garbage on terminal (most likely incorrect settings on my side).


#24

Ah ha I think we are talking at cross purposes SMB rather than Samba the software? On Dlink you could Samba as an add on piece of software. The SMB was with the CIF issue with the fall update in Win 10.


#25

Can i please get a copy of the image and instructions to debrick a my cloud home 2tb. thanks.


#26

And you must change the file in Sections 18 and 19 “etc / disk_white_list.xml” and make the model YOUR HDD


#27

Hi, See topic, links and manual on reddit.

jaredc23 wd@discoursemail.com 20 сентября 2018 г. 2:00:11 ПП написал:


#28

Is their a way to enable the factory cloud stuff on the restore? I also got the restore to work, but i can not connect to the website management, using 80 or 9091. The public share works, and the unit has a valid dhcp ip.


#29

Is their a restore image like this for the my cloud gen 1?


#30

No, only LAN usage, Amazon keys is cutting. Install Entware and get cloud and other app


#31

This is image for WD Cloud Home only (possible its worked for WD My Cloud DUO)


#32

Hi itsmanslife,

Have you managed to run the opkg nfs-kernel-server package on Entware?
when I run:

/opt/etc/init.d # ./S57nfs-kernel-server start

I have the following error:

Starting NFS server
mount: /opt/var/lib/nfs/rpc_pipefs: unknown filesystem type 'rpc_pipefs'.
mount: /proc/fs/nfsd: unknown filesystem type 'nfsd'.
./S57nfs-kernel-server[76]: can't create /proc/fs/nfsd/max_block_size: No such file or directory
rpc.nfsd: Unable to access /proc/fs/nfsd errno 2 (No such file or directory).
Please try, as root, 'mount -t nfsd nfsd /proc/fs/nfsd' and then restart rpc.nfsd to correct the problem
rpc.nfsd: unable to set any sockets for nfsd

Thank you for your help


#33

I totally agree!! I don’t know what to do to reach WD and share this problem, So many reviews and comments already present but WD doesn’t want to do anything about it. They should push some update and allow basic functionalities like ssh, ftp and SMB.


#34

Guys, Im noob in linux, how to edit files if they are read only?


#35

i would like to install full debian any instructions, please?


#36

put in rw mode… becareful can kill the system

system/bin/mount -o rw,remount /system

to return back
system/bin/mount -o ro,remount /system


#37

All sorted, mounted hdd in Win10. Thanks for all help AbuG. All I needed was transmission, works ok if file is less than 5gb. 'Coz if its larger it shows no space in disk for some reason, but its ok :slight_smile:


#38

If you feel adventurous, you could try this and let us know if it worked :slight_smile:

Fully at your own risk


#39

Yeah I came across that before… It needs hardware fastboot mode and recovery mode where we can ADB without system loaded … Don’t think we can do that at will through hardware buttons
(possibly can though an ADB reboot command while system is loaded)


#40


Would jumping these get us into bootloader mode?


#41

You need uart adapter to stop the system from booting.

Anyway, it’s useless, there is no kernel for the realtek cpu.