Disabling services and speeding up My Cloud Mirror Gen 2 2x4Tb

More horsepower to the people!

Hello all,

I’ve bought my white garbage box (I have plenty of digital garbage which needed to be stored somewhere) on May 2017 after having good experience with WD My Book Live, and not so good experience with D-Link DNS-320L, expecting that Mirror Gen2 will provide me not only greater capacity, but more CPU horsepower and smoother DLNA experience with twonky and finally cloud services I need. I see in forums I’m not the first and neither the last who’s having terrible performance issues with WDMC. I’ll stop pouring my emotions about broken expectations now.
By the way, WD, if you’re reading this thread, I’d like to let you know, you did not get sold another 5x NAS this year because I could not recommend this device to my friends. They decided to pay extra €uros and get Synology.

To begin with, I’m very sure I have no network performance issues. LAN is gigabit everywhere in my house where possible, including gigabit fiber coming from ISP straight to SFP module in my router. Wifi is used only for mobile devices like iphones, iwatches and macs when it lays on my laps. With my old DNS-320L I was able to get 20 megabytes/second speeds easily via wifi. Cloud Mirror was not reaching this performance on cable.
I tried to perform full restore, switch off services I don’t need. Not to push it too much after loading big quantity of data. Many things were tried. Nothing helped.
In the end I decided to enable SSH and to stop two services:

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

This cure helped. Not so much, but helped. Later I found that two processes named ufraw-batch were still running, consuming RAM & CPU. By killing them manually, I’d say, miracle have happened. Sleeping beauty has woken up! File browsing on my mac, PC, and Debian-PC started to be fast. File browsing on the iphone app, mycloud.com website started to be fast. Everything what I need started to be fast. I’ve lost thumbnail preview for photos in the mobile app, but comparing options:

  • possibility to have thumbnails and never get file opened, vs
  • no thumbnails and real-time instant file open.

I chose the latter one.
Unfortunately this tweak is one-time cure and after rebooting white box goes back in coma. Processes are back on running again. Widely found on internet commands to disable indexing autostart, like below, do not work anymore:

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

Can someone help disable these and other unnecessary services?
In best case I’d need to leave running:

  • NFS/Samba/AFP;
  • Time machine backups;
  • FTP;
  • Cloud service for remote file access/share;
  • Cloud service for syncing folders;
  • iOS photo backup using WD app;
  • DLNA with Twonky.
    Regarding twonky, it would be good to let it run only when system is in idle mode. Now when files are being transferred to shares under Twonky watch, all begins with good performance, like 30mb/s. Then Twonky kicks in, starts to index and all transfer performance drops down to 2-5mb/s.
    There is one interesting workaround for this problem on:
    However I don’t really get what makes to get script executed from newly created share called “Scripts”.
    I’m not so advanced linux guy, more like Raspberry Pi DIY’er and how-to guide user for setting up various stuff.