Directory access but no file access MBLD

Hello everyone,

I have three MBLD’s in use and one of them is having this issue:

Everything was working fine until two days ago when one of my MBLD’s (DNLA enabled) didn’t show up on my PS3. At first, a reboot of the device seemed to do the trick, but when I was watching a video it suddenly stopped halfway and the device again didn’t show anymore on my PS3.

I looked in the dashboard and the only thing I found wrong with it, is that it said ‘no internet access’. Strange, because the other two MBLD’s are configured exactly the same and do not have this issue. I can access the device from my Windows7 computer (mapped) and see the directories and files, but when I try to open a file it says: ‘no such file’ or something like that.

My firmware is from january 2014 but I don’t dare to update now because clearly it is not working right and if the update messes the device up I’m gonna cry. What could be the issue? Anyone else having this problem?

  • Access to all directories via Win7 computer
  • NO file access via Win7 computer
  • MBLD states ‘no internet access’ (which it should have)
  • DNLA media serving not showing on PS3
  • Reboot solves the problem for a few hours, then it starts again
  • RAID is enabled
  • No users/passwords enabled for shares
  • Dashboard stats for amount of files on drive seems to be right
  • Already tried turning off the energy saver, that made no difference
  • MBLD HAS BEEN WORKING FLAWLESSLY FOR A YEAR (and no alterations were made recently)

Thoughts anyone?

Thanks! Peter

A thought. It works fine for a few hours. If there is some corruption on the firmware then maybe a firmware upgrade as soon as it books up might cure the problem?

Thank you for your reply Myron; I had thought of that but I did not dare take that risk in fear of a bad update.

However, I noticed that the outer casing of this particular MBLD was incredibly hot in comparison to the other two. And even though the dashboard states ‘temperature OK’ I decided to turn the device off for a full day. I turned it on yesterday evening and it seems to be running fine now and the outer casing is cool again.

If it continues to run smoothly for a few days, I’ll try the firmware update.

Nope, same problem :frowning:

However: it doesn’t seem to be the fysical drive! I have read and write access from my iMac with no problem. There seems to be something wrong with the drive mapping on my Win7 computer.

Hmm, I have to think about this…

The temperature measurement, I believe, is taken from the S.M.A.R.T. diagnostics on each drive. As it was generating a lot of hot air, I wonder if something had pegged the CPU at 100% utilisation which would generate a bit more heat.

What could cause this condfition I don’t know.

Have you got the log files out of the MBLD and examined them for anything that could be an abnotmal condition?

Thank you once again for your reply Myron, after some testing I think I have found the problem and thus the solution.

After the shutdown of the drive, the high temperature did not return. However, after a few hours of running the mapped drive was not accessible from my Win7 computer, nor from my mobile devices (uPnP). From my iMac, I still had read/write access to my files (afp). This got me thinking.

I recently added a ‘work’ folder to my share on that drive where my graphic designs are stored with a multitude of different file extensions. I seems that media sharing this folder caused a conflict in file serving. I made a new share with ‘media serving’ turned off and stored my work files there. And voilà: the drive has been running smoothly ever since.

In the future, I’ll make sure that any media served folder contains media files only and hopefully I should be fine.

Thank you for your helpful suggestions and consider this problem solved!


Glad I’ve been of assistance. on my Duo I’ve dedicated two (or three) shares for media sharing and all the other shares have media sharing turned off. I’ve also located the MBLD in a place where it’s also cool. This is in an attempt not to add more heat to the MBLD.

I do find that even with the MBLD being idle, there is still a fair amount of heat coming out of the top of the MBLD.

Still, what you’ve discovered is worth knowing. Thanks for the feedback.