Direct remote access via open port instead of

I would like to access my WD My Cloud remotely using a dynamic DNS address and opened port instead of I’ve attempted to set up remote access using the Settings->Network options. I have a Linksys E4200v2 router, and I’ve successfully opened ports for remote access to other devices (e.g. Raspberry Pis, Pogoplug, etc). However, my attempts to get this to work have been unsuccessful. Here’s what I’ve tried:

  1. Set up a “static” IP for the WD My Cloud on my router using its MAC and local (LAN) IP in the 192.168.1.XXX address range. This was done by reserving its local IP and MAC address in the DHCP reservations table.

  2. Defining two ports for remote access. This was first done using external ports above 1000 linked to internal ports 80 and 443 for http and https access, respectively. I also tried defining both external and internal ports above 1000 (e.g. 8080 and 8443).

  3. Setting up STATIC access within the My Cloud’s Settings->Network page. After clicking on the STATIC option, I then entered the My Cloud’s local IP address, netmask (, gateway (, and DNS Server 1, 2 and 3 that I use on my router. Under the General settings tab, I changed Cloud Access Connection Options from Auto to Manual, and then used 80 and 443 (and also 8080 and 8443 when I had the internal and external opened ports on the router pointing to these ports).

These attempts have failed. My first attempt ended up making the WD My Cloud inaccessible and I had to perform a system reset (via the reset button) to gain access to the unit. This was due to having the wrong netmask value. My second attempt with what I believe to be the proper netmask value did not prevent access, but also failed. This led to the unit reporting that access to the external ports had failed and the unit was connected to the internet via the relay server. My last attempt using the 8080 and 8443 external ports also showed that these failed and were using the relay server. In addition, the Settings->Network->Status field reported no internet connection. Attempts to access the My Cloud via the opened ports via my dynamic DNS server and these ports also failed.

What am I doing wrong? As stated, I’ve been able to gain access to other devices on my LAN remotely via port forwarding, but the My Cloud doesn’t seem to want to behave. Also, it would seem that the My Cloud should make the process easier by updating the firmware to prevent the wrong settings from making the unit inaccessible from the local LAN. Overall, I really like the My Cloud, but the details regarding remote access via port forwarding could use more work.

What are you trying to do exactly? You won’t be able to access the NAS UI from outside the network, unless you tweak the Apache server configuration. You won’t be able to use FTP to access your files, unless you open other ports and enable the FTP access. Remember that FTP doesn’t encrypt user credentials. You could SSH remotely to the NAS and trigger file operations there, I suppose.

Tweak the Apache server? I just want to access the unit directly, and not through WD’s relay server. The manual says this is possible and that such a direct connection is faster than going through their relay server. The unit has settings that allow you to open up ports for remote access via port forwarding, so I’m just trying to do so. I’ve read nothing about tweaking the Apache server. Incidentally, while I know that I’d have to open an additional port into the unit for FTP access, I’m really not looking to do this at this point. I just want to be able to access the unit remotely to be able to control it via its dashboard, and to access files remotely and I’d like to do so completely independently of WD’s relay server.

So I’ve been able to get the port forwarding to work using 9080 and 9443 ports opened internally and externally on my router, and using 9080 and 9443 in the Remote settings on the My Cloud. However, trying to access the drive’s dashboard directly via a call such as the following fails:

This comes up with a “This page can’t displayed” error.

I have also tried to access this using:

This comes up with an invalid certificate page, and if I click on the option to open the page anyway, I get an “Unauthorized access” error (also showing a certificate error).

Now that the unit appears to be using Port Forwarding instead of relay access, can I directly access the drive without having to resort to using It seems that I should be able to directly access the dashboard via a call to an open port (either via http or https).

I think there is a bit of confusion. You won’t be able to access the UI remotely.

The topic of relay vs. direct is different. It is how the WD servers interface with your NAS to provide Wd2go and WDMyCloud applications services (but not NAS UI access).

Well, I stand corrected…

The unit reported that it had established Port Forwarding connection, but only transiently. It now again reports that it is using the relay server because it failed to connect on ports 9080 and 9443. What’s going on here? Do I need to use a true static IP address, or can I continue to use the DHCP reservations approach? Is there something else here that is not working properly?

You can use a static IP address using the DHCP setting in your router. Several users recommend to use an IP address outside of your DCHP address range.

On my unit, I have turned on UpnP, I have the NAS portforward setting on auto, and I let the router open the external ports to make it work. I was also successful at setting this manually (ie forward specific external port of the router to the NAS, and reflect these external ports in the manual port forwarding settings on the NAS). Both work.

In both cases though, I have noticed I’d have to reboot the NAS for the port forwarding to work.

I guess I am confused. So you cannot administer this NAS remotely? What if you want to open a share or control a Safepoint backup from work or when out of town? What about if you need to add a new user? You really have to access the My Cloud from the local network??? Is this also true for other My Cloud devices (e.g. Mirror, EX2, EX4)? If so, this significantly cripples the functionality of this NAS.

It is very risky exposing the WD Dashboard publicly on the internet. If you were to tweak apache to allow external access, with the existing API, one can view some info about your NAS without password eg the user list.

If you really need to administer your NAS externally, what I would recommend is that you do ssh forwarding. Open a public port eg 2222 on your router to the NAS ssh enabled port 22. All you need to do is to setup port forwarding on your external ssh client localhost:8080: :80 and ssh to this port 2222 from the internet. Open the your browser and point to http://localhost:8080/UI/. I’ve done these on mobile access.

Since your ssh is now exposed, please do some security touch up on your sshd like disallowing root password logins.

Tip: You need to specify your NAS ip not hostname/ eg assuming is your NAS ip. You can also forward SSL port 443.

Maybe this is what you’re looking for

I tried it and it worked. The link will be in this format:


Thanks everyone for the advice regarding access to the WD My Cloud unit remotely from the internet. It seems that this is clearly not a feature that WD supports and requires some “fudging” to get working. I will certainly try the recommmendations. However, I’m quite disappointed by this. While I understand the potential security issues associated with this, it is really not any riskier than having the ability to remotely administer other LAN devices like routers or IP cameras. In fact, Synology allows more than one approach to remotely access their NAS devices, including through a relay server or using port forwarding and direct access via the internet. I realize that the WD My Cloud single drive unit is really an inexpensive NAS solution (at most, only about $40 of it is dedicated to the NAS… the major cost is the Red drive inside). However, the Mirror, EX2 and EX4 units approach the price of Synology and other SOHO NAS devices, so the lack of support for remote NAS administration is surprising (or is this feature only hobbled on the single drive My Cloud?).

I am still having issues with port forwarding. My WD My Cloud reported transiently that it was connected via port forwarding after I did as described above. That quickly failed and is back to a relay server connection. I know that this is likely due to some configuration issues between my Linksys E4200v2 router and the My Cloud. But, it would be nice if this were easier to set up. Why not provide a utility to do this, as the Synology does?

Very dangerous approach!

Sorry, what is a “dangerous approach?”