Digital 5.1 Audio (DD and DTS) on HDMI not working?

It seems that the latest firmware also has the bug that HDMI does not carry dts or dd 5.1, neither to a TV nor to an AVR connected using HDMI. This was working in 1.02.21.

Could people please confirm this?

Also, could someone within WD please comment on this issue.

I know my own setup is not common (WDTV to TV then TOS to AVR), but it should work and does at the moment with the 1.02.21 rollback)

Additionally, people connecting the WDTV with HDMI to their AVR and then to their TV would most probably prefer to hear sound, but do not seem to get any.



kraemer:   WD did comment on it.   Go search for Guy_K’s posts in the previous threads.   His answer was specifically to the poster’s questions on DTS-HD, but it applies to more than just that.

Thank you for the answer.

Tony, I guess you are talking about this reply.

I am not sure that qualifies, because you yourself state in the very same thread that it is only a DTS-HD issues.

I am talking about files that come with Dolby Digital 5.1 only, like HD material I recorded off the tele.

So let’s see. I just wanted to know if that issues still exists with the new upgrade and the question, thus, remains open and quite unanswered.

yeah, i found the same bug like you do, is not sending dd 5.1 or dts 5.1 over hdmi but only silence, and if you play an iso dvd or dvd folder dd 5.1 or dts 5.1 is downmixed to stereo, this happens if “digital” is chosen in audio output setting.

this is a serious bug that should be fixed for the next update.

You’re right, it’s a serious bug, but it’s not affecting many people.

According to WD, the Live is trying to interpret Audio Capabilities via EDID, and it’s not supposed to be doing that.   Audio EDID data is supposed to be ignored.   Both of my Live’s are working fine with all 5.1 audio set to DIGITAL, so it’s very likely that your audio equipment is sending bad EDID info.

Either way, I am hopeful it will get fixed soon, too…

EDID seems to be the right direction. I have the WD TV live connected to the HDMI/DVI port of my TV, so that maybe implies no sound. I should try the other HDMI sockets. The TV tells the bluray player to downmix to stereo (which annoys me but is, according to LG, a desired feature) so it is sending “bad” (from Samsung’s point of view correct) EDID information.

I can’t be fussed to do that though…

Obviously, the firmware 1.02.21 ignores this information.


I have two units and both have the same digital audio over HDMI problems after last two updates.

I’ve been using 1.03.49_B for some time now and like it except there is no sound but noise on Blue Ray files with DD True HD. I use HDMI cable connected to the Viewsonic 6531w projector and I have regular audio Line Out on projector connected to the speakers with subwoofer. I am not even sure if I had sound before on DD True HD files. But in any case, that would be my request in future firmware to be able to downmix ANY sound format to ordinary stereo through HDMI output using the setting Stereo in the WD settings

Any fix yet ?  How about a work around?

shunja wrote:

But in any case, that would be my request in future firmware to be able to downmix ANY sound format to ordinary stereo through HDMI output using the setting Stereo in the WD settings

Can’t you get that by setting audio to Stereo? That worked on mine.

I just tested the latest firmware 1.4.17 and this issue is still not resolved.

Same problems…with my TV

Actually the problem not happen in 1.02.21 (i’ve tried rollover from 1.04.17v)…

after that, the firmware keep send “crazy” HDMI negotiation issue and no sound for “almost” all DTS movie :((

but if we rolled back, we lost a lot of Internet content :((

Exactly my point. For me this means that I have to buy a new AVR if I want lipsynced 5.1 Audio.

Please WD, fix this problem.

I had no issues with version 1.02.21, but had other issues which pushed me to update. Back then DTS and DD worked perfectly over HDMI.

Now only DD works this way and DTS is no longer sent thru the HDMI cable. However when I connected a digital cable (optical) between the WD and my Home Theater it worked again for both.

I think WD solved an issue with MP4 and disabled DTS in the process, but like I said it is working thru the digital optical cable… which is not good for me because that is how I connect my TV to the Home Theater.

Tried with 1.04.17V, using Optical Cable direct into Sony HT DAV DZ610

Set Options to “Digital without HDMI Audio”

MKV files with DTS worked mostly, sound came out and Sony HT says it DTS Audio

but still, some MKV/MOV no sound :frowning: