Difficulty in connecting an old WD Caviar 24300 drive to a newer PC

I have an old 4GB Western Digital WD Caviar 24300 (and also a smaller Caviar 2850) that I am trying to connect to a Windows 7 PC with a USB 2.0 to IDE adapter cable. I want to image this drive (or at least copy most of the files) on to the Windows 7 PC. The drive will NOT show up at all in my list of connected devices no matter how long I wait. Is there a driver I can download (free or purchase) so the PC can recognize this hard drive? I have been able to connect other drives successfully (Maxtor, Seagate, etc.), but just cannot connect to the WD Caviar 24300 or WD Caviar 2850 drive. I have also tried connecting it to a Windows XP machine with the same failed result. Any suggestions out there?

Are you sure that the drive is working fine ? Try another adapter :slight_smile:

Yes, the drive works fine when it is reinstalled in the original machine. I have tried 3 different adapters so far with no luck (Digitus, Sabrent, and Vantec). I am able to successfully connect to a WD Caviar 43AA hard drive but not the Caviar 2850 or the Caviar 24300. These drives do however show up in the ‘Device manager’ but I can’t do anything with them there. I need them to show up as a drive in ‘My Computer’ ???

What OS does the original computer have?

if they show up in device manager, than the physical connection is OK. You may need to initialize the drive by right click into the left, grey column.

Windows 95

Might be a good suggestion…but I need to backup this hard drive and do not want to lose any data at all. The next step after initializing the drive is to do a ‘New partition’ or ‘New simple volume’ to become readable but that will delete everything and format the drive - which I definitely DO NOT want to do. Are there any safer alternatives?

if this message appears, be very carefull! This means that the file system on the existing drive is broken or corrupt and cannot be used by Windows anymore! Handle with care now!

Ok thanks, I’ll be careful in ‘Disk Management’ when checking my Caviar 2850 tonight. As for the Caviar 24300, I will not be able to check this drive again until the weekend…

i think only windows 95 and 98 have drivers for it :confused:

good luck

should work on at least xp… but xp is running on another desktop so it may be a bios issue

My thoughts are more in this direction. If it is a simple cable, than this may cause the issues.
I recommend the usage of a HDD docking, internal IDE to external USB. I am not sure if a simple cable would work.

o had an external cable and it failed more times recognizing the hard drive than it worked

thats a good idea

if you have an old computer with IDE conmnection using xp for example in theory should detect the hard drive

Thanks for the suggestion of connecting to a HDD Docking station. Does Western Digital manufacture their own brand of these? If not, is one from, let’s say, Startech.com a good choice?

HI SuperTech99

no, we don’t manufacture or offer such HDD Docks. Don’t buy the cheapest one :wink:

Success! A HDD docking station from Startech.com (UNIDOCKU33) connected my WD Caviar 24300 (with the jumper at factory setting) to my Windows 7 PC and was recognized as a usable drive in Disk Management and ‘Computer’. I can now backup the drive successfully. Thank you @Joerg_A and @DavidSucesso for your help!

1 Like

Hi @SuperTech99

Does this work for the caviar 2850 too? with the Startech adapter UNIDOCKU33?? I have the same problem as you.

Unfortunately, I could not view the contents on the Caviar 2850. I could successfully connect to it (it showed up in Device Manager), but it came up ‘Not Initialized’ in Disk Management…and when I tried to initialize it (which may have possibly reformatted it anyway), I got the message ‘The request could not be performed because of an I/O device error’. I did not know the condition of the drive when I received it - it could have been bad to begin with. If it was known good, the UNIDOCK33 may have been able to read it…not sure.

Hi, I tried with the same UNIDOCKU33 and not works, I can connect others hard drives but the caviar 2850 doesn’t works, make the same as you do.