Difficulty deleting / moving files around, once they're on 2TB MyCloud NAS

I’m new to the MyCloud community.  I recently bought a 2TB MyCLoud NAS to use specifically for as an NAS device for intRAnet access, not internet “personal cloud” storage accessible outside my home/biz LAN.  The price was right and it looked like it would do the job and take the load off my desktop PC which has been my “server” for years.  I live off-grid in Wyoming and was also looking to reduce the electrical load on my older solar power system, so the small NAS was a good-looking solution that would use a fraction of the juice the 650 watt P/S in my PC requires.

I am having problems moving files and deleting them, once onto the NAS drive.  I’ve tried my Win 7, Vista, and XP machines, and my Android devices, too.  All result in similar strange failures.  I’ve only seen things like this in the past when there were FAT problems.

EXAMPLE - I have a folder on the MyCloud drive called “VIDEO”.  Within that parent folder are multiple sub-folders (genres) of home and business videos I’ve produced over the years.  I can drag new videos into that parent folder, but when I try and move them (using Windows Explorer) into any of the sub-folders, I get various errors, from “file is wrote protected” (they aren’t) to “file doesn’t exist in that location” and then the file I tried to move appears to stay in the parent folder.

However, the file I tried to move WILL move in the target sub-folder, even tho’ I got the error messages.  Hitting F5 on my keyboard refreshes the directory tree and then the parent folder no longer includes the file I tried to move.  (If I try to move multiple files, only the first one makes it to the destination and all the rest remain after the error message.)

In Android, ES File Explorer just says, “Task Failed”.

Am I supposed to be using proprietary software to manage files once on the network drive?  What’s am I doing wrong?

Thanks for any help!

This one i know too :slight_smile:

Its because of the folders having different file permissions.

If you get ssh access to the drive and take a look at permissions, you will see the owner of those folders is different than the one you are using to map the network drive with.

Perhaps using transmission for torrent downloads? those most of the time(unless changed) get created under user “root”. So if you then try to move that folder in windows to a new place you will have those error messages.

I had this same problem out of the box (not using Transmission or anything non-stock). Setting a user password seemed to help for a bit but strange security related things kept happening. It got worse: