Device offline - help needed

Hi, been using mycloud 2tb for about 4months and had no problems until last week accessing remotely via pc or iphone via 3g.

All of a sudden its just stopped working on my iphone using the my cloud app or browser. I can still access on the phone via wifi but any form of remote access outside of my wifi network just times out on a browser or the mycloud app says the device is offline.

I havent had any phone updates or updated the mycloud software as far as i know so im at a loss as to what to do. Any advice/help very much appreciated.

Try to generate a new access code from the NAS UI and enter this access code to create a “new” access to your Cloud from each app. Does it solve the problem?

try to within the dashboard\settings\utilities\Device Maintenance to reboot the unit.

Yep tried this. Deleted the device as well… Still no luck

Reboot doesnt help, tried that a few times…anymore suggestions? Im really lost with this one

Well… I had some issue with not being able to access the device. Here is what I did. Not sure all the steps were necessary or they will be your solution:

  • removed the device in all the apps (+/- sign on the top right on iOS, for example)

  • on the NAS:

– removed all the devices from each user

– disabled/enabled cloud access for each user, registered all users on

– generated new access codes for each device.

Tried that… Still not working. Any further ideas? Does the support line help with this sort of thing?