Device needs reboot constantly to connect

I’ve had my WD MyCloud device for a year or more. Worked fine for most of it. For the last month, it’s been dropping offline daily. I have to pull the plug and reboot it. It’ll connect for a few hours, maybe a day before doing the same thing.

Another new issue it’s doing, I cannot access it from iOS devices from outside my network via the App. I can, however, go to the WD Site and access files via Safari on the same iOS devices from outside my network. But on my wifi at home, both the App and the Web access work.

Running the latest firmware and app. No changes to my router or ISP. Thoughts?

Wired access or wireless?

Intermittent wired network connections could be due to degraded electromechanical connection; unplug the Ethernet cable at both ends (MyCloud and router), check for dust, dirt, corrosion. Stick back in the sockets and jiggle a bit to break any oxide that may have formed.

Other possibility is that there’s an electronic problem with the network driver at either MyCloud or router; try a different router port.

Finally, when did the unit last upgrade its firmware? Does that coincide with the start of problems?

Have your checked the error log files (in /usr/log I think)?

I did a total factory restore on it yesterday. Upon setup, I get these error messages:

Web access account cannot be created. (250008)

WHen trying to enable cloud access:
Internal Server error. Retry your last operation. (200500)

When trying to add users:
The requested service was not found (200404)

My router is a Netgeat C6300 with Comcast Xfinity as the ISP. The WD Mycloud is the 3TB model with the current firmware. I have replaced the ethernet cables, still no luck.

Hi HalTool,

Have you solved your problem? My MyCloud device has started exhibiting the same symptoms as yours : it’s dropping offline daily, and I have to pull the plug to make it work again.