Device locks up when I plug in an external harddrive

I have the 3TB model with latest firmware.

I also purchased a 3TB My Book (latest firmware).  

The external drive has thousands of files on it.  When I plug it into the MyCloud, it appears briefly under the “USB Devices” area… but then the web UI becomes unresponsive.


  • I can ping it

  • I can NOT access any shares

  • I can NOT use the web UI

  • This happens consistently with this device as well as with another external drive.

The device is toast until I pull the power.

Anyone else experiencing the same?

Thanks in advance.

If it happens with any USB drive, then either yours has a bad USB port or a new random bug.

If you can, do a quick factory restore on the WD My Cloud and try again.  Also try with another usb i.e. thumbdrive after. 

I plugged in a 32GB thumb drive and it worked fine.  Ejected it using the web UI.

Did the “System Only” restore & then plugged in the previous drive.  Same problem.

The drive mounts as a share for a small amount of time (less than a minute or so) and then the MyCloud becomes unresponsive.

Not sure what to do from here. 

  • I tried disabling the media scan, same issue.

Next up might be to format the external drive and try to mount it empty.  Perhaps I’ll add a few files at a time and judge stability.

I have exactly the same problem. It started occuring after the most recent Firmware update. I have the 2TB model with a 2TB USB HDD plugged in. As soon as I disconnect the USB disk, the unit works as normal and can be accessed via Apps or simply via the Public folders.

Update - I did a ‘full restore’… took about 11 hours to do.

After that completed, I connected a 3TB USB drive to the external port… some problem occured: Drive stopped responding until I unplugged it.


New to the community and just purchased and set up my 3TB My Cloud. I’m having the same problem when I connect a 1TB Dell USB 3.0 PORTABLE drive. My Cloud locks up and I need to reboot for access. It runs the latest firmware. I will try later with a WD 2TB portable drive and possibly with a  POWERED IOMEGA external drive.

Otherwise it’s working well and I’m so far impressed with what it does.

Same thing for me.  Perhaps piling on will get some notice and a fix.  Basically this 3TB storage is junk.  If I could only get my money back.

An Update… 

o Portable WD 1TB USB 2.0 drive was recognized and accessible when plugged in. However, My Cloud locked up while I was attempting to edit the security permissions via Win Explorer. It got through it for about 80% before it croaked with message that the //WDMyCloud share had dropped it’s connection (roughly worded…). The light remained blue throughout. I’m thinking it may not have completely scanned the device before I attempted the above.

o EXTERNAL 2TB USB 2.0 Iomega drive was properly recognized and is working properly.

In all instances My Cloud was working properly before plugging in the drives.

The question then, is the problem with the USB 3.0 connection?

Has anyone successfully connected an USB 3.0 external hard drive to the 3TB My Cloud?

I have a wd elements usb 3.0 drive and it works.  There is an update out today, try updating to that fw as it addresses some external usb issues.

Upgraded to the latest firmware v03.01.04-139 and still have the same problem.

Got another 3TB USB 3 My Book drive today… only the default content on it.  Plugged it in & it seems to work.  Go figure.  I suspect it is the content scan failing… seems as though some content on my other drives (music?  images? bad filename?) is causing the failure.

So - I now have two identical 3TB USB 3 My Book drives.  One works, the other does not.

I have one other external HD (USB 2) that causes the failure.

I have a 32GB thumbdrive that does not cause the error.

I suspect I could shuffle some files from one drive to another and cause a failure… perhaps I will try.

WD sent me a replacement 3TB USB drive.  I am experiencing the same problems with it - with latest firmware.  Working with the WD engineers on this.  They seem very helpful - hopefully will get a resolution.

I’m having these same problems… any updates on when this will have firmware that works properly?

Due to lack of enough user responses, we couldn’t go any further to solve this issue. 

1 Like

Is anyone still have this issue? 

I still have this problem. This is the way it happens.

With new wdcloud without upgrade, I only could see wd external harddrive

I upgraded to firmware 3.03.01-156 and I was able to see a seagte 3t b hard drive. However, when I usea a USB 3.0 hub, I could see both drives (both are usb 3.0), however deviced locked up after 10 minutes.

Then I tried with a usb 2.0 hub, and I was able to see both devices the whole time, how ever lately wdmycloud has been locking up when I connect both devices thru the same usb 2.0 hub. Maybe is something with the sequence or the port where I connect each hard drive. Also, usb hub is also a card reader and only has 3 ports. When I see it in UI, I see 3 devices , my 2 hard drives, and another device with 0KB. I havent connect a third hard drive.

Is the hub powered via AC or just through USB?  Might be the USB port on the My Cloud cannot provide enough power to all the devices.

The usb 3.0 hub used an external power supply, however the usb 2.0 hub I connected without the external power supply but it let me use both hard drives.

I have done many more test and I found this:

Using USB3.0 hub with external power, when I connect 2 or more hard drives, wdmycloud crash.

How everm using a USB 2,0 hub POWERED OR NOT POWERED, I dont have any problem using a  WD hard drives of 3TB. How Ever when I connect a Seagate Hard drive, wd mycloud crash. It doesnt matter if this is second or third drive I connect. However, If I only connect seagate hard drive, with or withou hub, I can see it withou problems.

So I think this is a problem with the brand or design of a different hard drive than WD and the USB3.0 Port.

Could this be fixed in nest firmware? In fact, 2 firmwares ago, wdmycloud never could see Seagate hard drive, so I supose this has a fix.