Device keeps freezing

So not only will my device not update the firmware, as per my earlier post today, the device has now frozen up 3 times today and I only bought it this morning.  My first thoughts when setting it up was that it was more impressive than the other media devices I’ve tried in the past, but unfortunately my first impressions are quickly disolving.  I guess I’ll be taking this one back to the store…

I agree with you!

Excellent cover flow, but the new firmware keeps the WD TV Live re-setting (re-booting) and if you try to play any film (mp4’s) it freezes and have to unplug it.

What version of the firmware do you have?

I have the exact same problem with the WD SMP. HDD WD 750GB USB 3.0 (WDBPCK7500ABK-EESN). Connecting the drive to the rear USB port  picture freezes and after a while WD TV Live tells me something like that the USB drive is disconnected.
This happens  when watching large files 1080p .
I tried firmware - 1.04.12  , 1.05.18 ,1.07.15 with resetting to factory defaults.No results.
The issue is described here.:

I had an issues since the firmware upgrade that FLV flies were freezing. Playing from an USB3 drive. From either the rear or front USB slot. Sometime after seconds, sometime after 10-15 minutes, but it kept freezing. Only FLVs. MKVs, MP4s, AVIs were all ok.

Before I started to kick the device into pieces I tried out my older USB2 device, and that seems to be a solution. Had watched like 10-20 FLV files (some of them those that previously froze) and had no problem.

I have bought this player as I used an old egreat one which has no any support now. So I decided that this new player will be great with it’s support and nice interface and internet features…

Well, so far was not the best trade of my life. :wink:

I was wrong. MKVs are freezing also. That leaves me to watch AVIs and MP4s… :cry:

I had to buy this one so I could start to appreciate the Egreat device.

This is incredibly annoying!!  My WDtv Live keeps freezing after 15-20mins of playing from my WD passport.

This started happening as of the last fireware that was updated.

Any help?