Device is offline. (668)

I was having no trouble using WD Photos.  Then I updated my 2 iphones to OS 4.0 and now I get the message “Device is offline. (668)”   The device is online because I can access it from my laptop when both laptop and phone are on the same network.  

Is this a known problem and if so what is the ETA on getting a new version of the app?

WD Photos 1.0.1 (latest in app store) works fine on iPhone 4. If you use MioNet webapp (login to www.mionet.com) does your NAS (under My Resources) show up as online?

You could try going to your NAS page and doing a stop/start mionet to see if that helps.

Have you resolved this issue? I am having the same problem.

It seems it’s just about waiting and repeating - all working well now…

I installed and succesfully used the app on my iphone 3GS on OS 4.0.2 both in my wifi network and on 3G. Once I turned my phone on and off again, I got the “Device is Offline (668)” message, and waiting and retrying didn’t help at all. Again, the device is definitely not offline. Any ideas?

Device is offline (668) - does not refer to the iPhone/iPod Touch online status but the status of the My Book World or ShareSpace.  A fairly easy way to confirm the device is offline is to launch MioNet Web ( http://www.mionet.com >> Sign-In).  The My Book World or ShareSpace will appear in the “My Resources” tab as either online or offline.  If the unit is offline then it is no longer comminicating with the MioNet servers.  The unit may appear operating normally on the home network, for example, but is no long reaching the Internet.

I have the same problem.Anyone found how to fix this?Tnx

I had to re-boot the “My Book”. That is done by inserting a paperclip into the re-set switch in the back, just by the ethernet cable connector and holding it for 4 seconds. Of course then I got the 660 error “File not Found” for about 10 minutes. Afer that everything was fine. This all occured less than a week after upgrading my iphone from 3.1.3 to 4.1. However, now everything works better because 4.1 allows a larger cache.

The problem is that your device is not automatically restarting the mionet service after a reconnect. Once the connections disappears the mionet web service will show your device as offline. Only solution: Reboot the whole device or restart the service in the web interface.

Here is the knowledge base article.

@WD: Please give us an option that the mionet service is automatically restated after the connection loss.

Hi

I have the same problem. Even if I can see the device through my PC, it is offline, because I cannot connect by using Mionet.

Now the question is how to put online Mionet. I hesite to restartt Mionet in this window (direct connection, see picture). Is that correct?

Many thanks

mionet.jpg

I tried stop/start mionet. That didn’t work.

Then I did reboot device from the dashboard on a local network computer.

That worked!

I too am getting device is offline (668) on my ipod touch. How do I fix this?

Hi WD-JohnL.

I logged in to mionet.com but did not see the “My Resources” tab. I assume this is because I am  on my local network.  All other indications that I can see seem to show everything is online.

Still no solution that I can see. I have submitted a support ticket also.

So what do we do when we find that the device is no longer communicating with the MioNet servers?

This is what I found since owning this device. I no longer have it set up to automatically turn off (energy saving feature), because I was constantly getting device is offline from my WD Photos App. I would have to wake it up from my home network or reboot the device. Since I have done that, I have never received a Offline message.

My suggestion, reboot the device and change the setting for energy saving since it seems it was actually turning the drive off and making it OFF LINE to the WD Photos APP when launched and attempting to contact the NAS drive, it wouldnt wake up from the WD Photos or Mionet trying to access to it.

Once you reboot, sign out of WD PHOTOS and Sign back in after a few minutes and everything should be accessible.