Device Driver software not correctly installed

I just bought a My Passport 2 TB Ultra drive

When I plug it in the install starts then fails.  In the task manager the the installation process says it still continues as seen in the picture below:

I am unable to click on the failure to see at which point it stops working though.

I’ve googled around and tried a lot of thing, including:

-Opening the device manager and uninstalling and reinstalling the drivers.  This is the only place the drive is recognized.


-Restarting the computer, including disconnecting from power sources and straight shut downs.

-Used the drive on another computer with which it worked just fine.

-Went through computer management to see if the drive would show up there and it does not.

-System restored to a point before my last windows update, then tried it, then reinstalled the update and it still didn’t work

-I also found where the drivers installed on my other computer, copied the folder with a drive that did work on both computers and pasted the drivers where they should go on my computer, still nothing.

Any help would be great.  I don’t think this situation is a repost since I’ve scoured the forums for the problem.

Does the drive still show on the computer even when the drivers are not properly installing?

Try to see if the drive appears on Computer and Disk Management.