Device doesn't see network content


#1

I just  bought & installed a WD TV Live Hub.  The install went pretty much as expected including the wireless  setup until I tried to view some network content.  There’s no network content visible.  I’ve tried various settings and skimmed the manual but no  joy.  Anybody know what’s going on?


#2

Have you set up network shares, or are you using a media server?


#3

I’m not sure what you mean by “setup network shares”.  There is a setup option to toggle network shares on/off and it is set to “on” but I’ve seen no further options.  In my list of video options I have both “network  shares” & " media server" & also “local content”,  all of which are empty even though I copied a video from a network  HDD to the device as a test.


#4

Set your source to local storage and you should see it. You have to set up shared folders on your computer or NAS, or run a media server to serve files to the WD.


#5

My network files are all shared.  I have another WD media player that has no problem seeing my network HDDs.  I have also used the “tool” I was told to download to map the device so it would appear on my network computers.  I’m beginning to think  this thing just doesn’t work.


#6

If your other WDTV can connect to your PC, then it is probably something to do with your firewall, antivirus or router.

You can temporaily disable your firewall & antivirus.  If that doesn’t work, you can try resting your router, usually just unplugging it, waiting a few mins. then plug it back in works.  Or, access your router and make sure that it isn’t blocking the HUB’s IP.


#7

If there was a problem with the firewall, AV or router it would affect both devices.  The new WD found and connected to my LAN without a problem.  As a test, I watched the video I transfered to the WD on one of the network computers.  It played perfectly.  For some reason the new hub cannot see the network devices even though it is visible on the LAN.   I have contacted tech support.  If they can’t tell me what I did wrong it goes back to Best Buy.


#8

No, it would not nececcarily affect both devices.  I had the same problem after installing a new router.  I could connect to one PC, transfer, access files, etc., but the other PC couldn’t connect to that PC, even though it could access the internet.  Resting the router solved the problem.

And you firewall wouldn’t keep you from access the HUB’s content, only block the HUB from access your PC.


#9

I think if I had any of those problems I wouldn’t be able to stream Netflix and it does…perfectly.


#10

As I said, it wouldn’t cause you from not being able to connect to the internet (or stream from Netflix), it would only cause you not to be able to connect to a PC on your network.


#11

ram1009 wrote:

I think if I had any of those problems I wouldn’t be able to stream Netflix and it does…perfectly.

You haven’t told us what you are using for your server.  Is it a PC, a NAS, what is it?   What version of software?

As Tinwarble says, PC-based firewalls can make rules that are specific to an IP address.

Go shut down the WDTV that IS working, and then use ITS IP address on the Hub.  See if that fixes it.

Regardless, don’t forget to change things back so you don’t duplicate the IP address on both devices…


#12

The users manual for this device doesn’t say anything about designating a server.  I have a LAN consisting of 2 wired PCs and 1 wireless PC all desktops.  I have large HDDs in all which are all visible to each other.  My other WD player is currently on RMA to WD for choppy playback but it had no problems like this one does.  However, it didn’t have a HDD either.  This conjecture about firewalls and routers seems far fetched to me.  The router is obviously communicating with the player, and the PCs can all see the player’s HDD.  I’m on my way out the door to work now but I will shut down the firewall tonight unless I hear from WD tech support. 


#13

THE ROUTER isn’t involved.    If your PCs and WDs are on the Same Network, the router has no involvement in the traffic.   It’s the PC FIREWALLS we’re talking about.


#14

I don’t claim to be a network guru but it’s obvious that the individual components on my LAN communicate through a router so I don’t see how you can say the router isn’t involved.  It’s certainly capable of blocking communication however (I believe) such blockage would be two way blockage.  In other words the PCs wouldn’t be able to see the player which they can.   I am less knowledgeable about firewalls however I believe the same is true of the one I use which is the one provided by Win XP Pro sp3 which (I’m told) is not very sophisticated.  I’m at work now and hoping to get some input from WD before I get home tonight.  If not, I will disable the firewall temporarily to see what happens, however I’m not optimistic it will matter.  Remember, one thing I did as a test was to copy a video from one of the PCs to the WD HDD.  I did this using the PC to perform the copy.  I then played the video back on the PC I copied it from over the LAN.  It played perfectly even over a wireless connection.  That same video was/is not visible to the WD device as “local content”.  All of these little clues lead me to believe that there’s something wrong with the WD device, not my LAN.  I could be wrong but that’s what the evidence points to  from here.


#15

By definition, two devices that are on the same IP network do not talk through a router.    In fact, it takes some significant trickery to get devices on opposite sides of a router to talk to one another if they are on the same subnet.  By definition, a ROUTER only moves traffic between DIFFERENT IP subnets.    A SWITCH or HUB is what moves traffic from one system to another on the SAME subnet.

The cables might be connected to the box, but I guarantee you the “router” part of that box isn’t part of the equation.   it’s the SWITCH that is INSIDE the box that is moving the traffic, not the router itself.   And the Firewall is a probably part of the router, so by extension, the Router’s Firewall cannot interfere with the traffic.  

Software firewalls are not usually bidirectional.  The policies define the direction of the traffic.   The affected PC may be allowed to discover outside devices, but those outside devices may not be allowed to discover the PC.   The policy depends on which device ORIGINATES the connection. 

I think you’re having problems understanding the fundamentals here, but that’s beside the point.

If you transferred a file to the Hub’s HD and the hub doesn’t show you the file after you do the steps I told you earlier, yet the file DOES appear to PCs when you look at the internal drive through the network, then that means the file you put on the hub is most likely not supported by the hub.     The Hub will NOT show media files that are not supported.   Exactly what kind of file is it?   What’s its full filename?   Do you see the SAMPLE CONTENT when you change the view to LOCAL STORAGE?


#16

Well, as I said, I’m no network guru.  The distinctions between a router, switch & hub are lost on me.  I see items with those names advertised and have never been able to find satisfactory definitions of the differences between them, although I’d like to.  The video file I copied to the WD HDD was the “video TS” folder of a movie I ripped to the PC’s HDD.  It contained the unencrypted content of the original DVD.  You probably know that’s mostly *.VOB files.  I didn’t copy the “audio TS” folder because it’s empty.   The “sample” files on the WD HDD are visible and playable.


#17

Alright then, that’s something.

At least we know that the Hub sees its internal drive, and sees the content partition.

Did the MEDIA LIBRARY get recompiled after you moved content onto the drive?   If not, or if you’re not sure, go to the SETUP / SYSTEM menu and select DEVICE RESTART.    It will reboot and recompile the media library.

How do you have the FILTER set?   Try setting the filter to FOLDER or ALL.

What was the DESTINATION folder you copied to?  Did you copy it to the ROOT of the drive?    If so, you should see

“VIDEO_TS,” “Sample Media,” and “USB_SYNC” as the first entries when you browse into Local Media.  You might NOT see USB_SYNC if you never used  that function.

Was the folder you copied called “video TS” or “VIDEO_TS.”   The difference is critical.  It *MUST* be labeled “VIDEO_TS” to work correctly with DVD navigation.


#18

I can’t answer any of this until I get home tonight.  Thanks for your interest and patience.  I’ll post again when I can respond to your questions.


#19

HERE 's a little reading material for you, maybe you’ll find a satisfactory definition.:wink:

The reason for resting the router (or should I say restarting, which is what it really is by pulling the plug) is sometimes the firmware on the router messes up and restarting it fixes things.  This could be an issue in that the router is not delievering the data packets were it is supposed to.  This is no different than rebooting your PC when it freezes up.

Also, your firewall acts like a barrier to keep things out of you PC, not the other way around.  And just because you can connect from one device to your PC doesn’t mean that the firewall want block another.  The firewall on your PC also does not block another PC or device from accessing the internet, it only keeps another PC or device from accessing the PC the firewall is on.

As for your AV, it can also keep something from connecting to you network.  I don’t know if it is still a problem, but when Norton 2011 came out, it was causing people with my other media player (Seagate Freeagent Theater+) to not be able to connect to their PC, not really sure why as I don’t use Norton.


#20

OK, here we go.  I have power cycled the router (30 seconds off time) and restarted the hub as instructed.  Neither had any effect.  I cannot find any mention of a filter.  The folder I copied my video file to is called “.wd_tv”.  The folder I copied is called “VIDEO_TS”.  Something I noticed, there are two folders titled “Sample Media”.  One of them is in the root directory and has many sub folders with lots of files.  The other is in a sub folder of the “.wd_tv” folder called “thumb”.  This folder has only 3 files and is the only one visible to the hub.  I’m going to eat some dinner and then kill the firewall & AV.  I’ll check back later.

I’m back.  I have turned  off the firewall & rebooted both the router & hub while off.  No Joy.  I can’t figure out how to turn off Microsoft Security Essentials.  Any more suggestions?  By the way, this WD Discovery tool is kind of funky.  I can’t figre out what it’s suppose to do.  The only network drive it sees is the WD hub and if I try to “configure” I go to a web page which asks me for a password I don’t have.  What is that all about?