Device does not start in Main Menu

Whenever I start my device it always defaults to the Video > [shared folders] listing, where we store most of our files for network streaming. To access Netflix or music, I have to exit back to the main menu and then select Services , etc. The only time it displays the initial WD loading splash and main menu is after a reset or boot, so I assume it is usually in some sort of standby mode for quick access.

Is there a way to set it so that it always starts with the Main menu first? It 's a bit of a pain always having to back out of the Videos folder all the time to access Music or Services. This seems like it would (or should) be the default setting but I can’t find any way to change it.

Any suggestions?

???

I’ve never seen that behavior…  Mine always starts at the main menu, whether from a cold start or a startup from standby.

This is what I figured would be the normal startup…something must be wonky. I’ve edited the original title to reflect this as an issue rather than a setting preference.

Are you by chance using a universal or programmable remote that might be sending an errant “OK”?

Hmmm, good point. I use a Harmony One and checked the settings for my WD Live activity:

Western Digital Media Center PC   |     Western Digital Media Center PC  is set to “Video”

It seems to want an input setting for WD Media Center PC even though there is no real input setting. Have to fool around with it but I’m sure this is where the errant signal is coming from.

Thanks!

Ahhh.  Yeah, that will definitely do it.

I use a Harmony One, as well, and I don’t set any “INPUT” for the WD devices.

Just delete that part of the configuration for that “activity,” and it should be OK.

Yep, confirmed. The Harmony One comes up with the following setup options:

What input or channel does your Western Digital Media Center PC need to be on?

o Music
x Video (Recommended)
o Photo
o Settings

o Source input is missing

So I’m not sure how to tell it no input…? The only devices in the activity are TV (set to HDMI1), Receiver (set to the WD LIVE input, which in this case is CBL/SAT), and the WD LIVE itself, which shows up in the database as a media center PC.

I used the WATCH TV activity as a template, maybe I should try another type and see what happens.

Using the Utility > Generic activity did the trick. No need to set input for the WD.

Thanks again, this has saved me lots of headscratching :slight_smile:

If I recall, I just selected “Source Input Missing.”  But if you got it working otherwise, I guess that’s moot.  :)