Detection of photos

I have a 4 TB My Cloud drive.
In “Content Scan” it detects 133 photos on a share called “mp3” (it’s detecting the album covers), but it does not detect several thousand photos on a share called “Fotos”.
I’ve read on some posts that you must put the photos on the Public share, under “shared photos” but
a) I don’t want to put them there because the Public share is… er… public and there is no way to make it private
b) why is it detecting the photos on “mp3” then?
Note: I do not want to turn DLNA media server on, as the driver becomes mad and basically useless when I do that.
Any solution to my problem?

Have you tried a reboot? See image below. Click, tap or activate image to enlarge it.


It worked, thanks! All it needed was a reboot after all. I feel very dumb.
But it doesn’t make sense that it couldn’t scan the files without a reboot. Surely I’m not supposed to reboot the drive every time I add a media file…

I have never checked but I have my desktop set to backup two times a week and my laptop once a week using WD SmartWare… I shut down my My Cloud once a week and restart it as part of my computers and network maintenance. I do the same to my desktop computer and router. My laptop is normally shut down after each use.