Deleting expired activation codes (error 400041 parameter missing)

Probably because I changed the MyCloud from DHCP setting to Static IP it was not possible to get an activation code for a device by clicking “get code”

 Now it is showing an “unknown unregistered device” with an activation code date somewhere in 1969.


When I want to delete the device or code by using the delete button I get an error 400041 parameter missing and the device or code is not deleted.


Any suggestions?

If you are unable to delete these entries after a reboot then maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

This is a long-standing firmware bug. Only fix is a system only restore.

I have the same problem with an activation code. I removed the account of one of the users, and right now it works. But still I don"t know how to get rid of it from “admin” account. 

Zrzut ekranu 2015-07-4 o 18.48.32.png

And another thing…

After uploading approx 1075 GB of data to my My Cloud 4TB, “WD My Cloud” doesn’t show me the capacity.

It’s keep scanning. (I store my data in 3 folders: 660GB,  25GB and 390 GB). 

When i tried to do a Quick System Diagnostic Test  /“Quick Test”/, it hung at 90%. 

How to fix it?