Deleted volume, Now won't read drive


I haven’t posted here in a while.  Truth be told, I forgot I had joined and sought out help.  Sorry!

Well, I’ve posted my problem in several other forums with not much help.  I’m getting a bit frustrated and ready to just throw my drive out the window.

I’ve been trying to fix my external hard drive.  It’s a My Book Premium Edition.  Originally, it had files on it…but all were deleted (except a few password protected files.)  I didn’t know the password, so someone suggested to try reformatting the drive anyway.  The reformatting didn’t finish and had errors; then, I couldn’t even save files to the drive.  Next, I was told to delete the volume, unplug, replug and format the drive.  So I did.  HOWEVER when I plugged my drive back in, my computer wouldn’t recognize it…so I can’t format it.

Interestingly enough, I decided to plug it into my sister’s computer.  (Her computer has Windows 7; I have Windows Vista.)  Her computer recognizes the drive, but as QuickData Y:  and Quickbooks X:

What should I do?  I don’t understand what is going on with it.  Should I just hard wipe it?  (Although, I don’t think I can if my computer won’t read the drive…)

Please help!!!

Does the drive appear on disk management?

Check if it does, it might show as unallocated

@Wizer:  Thanks for your reply!

Well for some strange reason, the other day, Disk Management recognized the external hard drive (but not My Computer.)  It recognized the drive as unallocated.  I assigned a letter for the drive and began formatting the drive NTFS (normal way, not quick way.)  After several hours, it was almost complete…but then, my stupid computer did Windows Update.  :(  So…I had to start over again.  This time, Disk Management recognized the drive as Disk 1 (healthy partition, blah blah) and RAW. 

I started formatting for the second time (NTFS again) and waited over 12 hours for it to complete.  Towards the end, a message popped up and said that formatting couldn’t be completed.

By now, I was beginning to get pissed.  I clicked on the drive again, tried to do a quick format (NTFS again), but it said the same error.  Then, I deleted the volume, unplugged it, waited, reconnected the drive, and waited for my computer to recognize the drive.  It recognized the drive as unallocated.

I assigned the drive a letter for the drive, and tried another quick format (NTFS.)  Still, I couldn’t format the drive.  Same error.  My last idea was to try formatting the drive as exFAT (that was my only other option.)  Didn’t work.

Any ideas?

The only other thing I can think to do is to hard wipe it with DBAN.  I’m not sure if it would actually help.  Would I just be wasting my time?

There are utilities that help you fix RAW partitions

just Google it

Sometimes the command prompt to convert a FAT32 partition to NTFS works since you formatted it you don’t have anything to loose.