Deleted MyBook install and can't connect now

Apologies if this has already been asked, but I have recently repartitioned my Mac hard disk and seem to have deleted the files that identify my network hard disk at the same time.  I can only assume this is what has happened as all my Time Machine backups have disappeared and I cannot connect directly to the drive.

I have tried to download the MyBook Live Setup tool but when it runs it does not detect the drive.  I have checked and the drive is connected via ethernet cable to my router and the power is properly plugged in.  The light on the front of the drive is solid green and there are two lights on the back, next to the ethernet cable.  One flashes, occassionally, and the other is a solid amber all the time.

Is there any way of re-installing the drive without using the WD installer (or am I doing something wrong with it?) or is there another way of connecting to the drive?  Any help would be very much appreciated.


Have you tried using the name of the device through the finder?

Also as a recommendation, you can try resetting all the devices on the network and check on the finder of your computer to see if the drive shows automatically.

Also note that if you were using the time machine software to do the backup, you will need to use the same software to restore the files.

Check on page 19 of the user manual for more information about using the drive on a MAC.