Deleted default files and now WDSmartWare doesn't recognize my MyBook

Hi everyone.

I recently bought a MyBook 3.0 2TB and I stupidly formatted the disk. Now it is completely empty and my PC recognize it as a “new volume”. Thus the SmartWare doesn’t recognize it…

Is there anything I can do to return the disk to it’s former state?

I tried a zipped file found on the WD site, I unzipped it in my MyBook, tried to run the “WD SmartWare.exe” but I keep receiving a message that says: “Application not started from drive”.

Any thoughts?  Thanks in regard.


You just have to update the firmware on the drive and download WD Smartware, click here to get all you need make sure you do step 1 and 2.-

I keep getting an error at step 2, when I try to install SmartWare.

Also, I have an older version of SmartWare in my pc, and each time I reboot my pc, I have to unplug and replug the usb of the disk so that my pc recognize the disk…

If your OS is windows xp, you have to install Microsoft .Net Framework 3.5. If you have windows 7 then contact WD Tech Support.