Delete Public Share Folder or Restrict Access

Excellent point!!

How can this item be on review for almost a year and WD doesn’t solve the problem.

jonclaud

EZ wdmycloudex4//share/public/access//off done. no need to worry or compromise

Unbelievable that anyone would even conceive of hardwiring the EX4’s public share. We admins should have 100% control over the accesses and security of any device we own, but WD shoots us in the foot here. In this day and age of massive cyberthreats, a security hole as galring as this boggles the mind. This fault needs correcting ASAP, not sitting around for a year on a message board waiting for action. It makes me wonder what else under the hood is screwed as bad as the public share fiasco.

Post!!!

Another Post!!!

HOW MANY PEOPLE WORK FOR WD?

HOW LONG HAVE WD BEEN CREATING PRODUCTS? SINCE THE 70s? (doesn’t seem like it…)

HOW LONG SHOULD A WD PRODUCT OWNER WAIT FOR ACTION ON PROBLEMS?

SERIOUS PROBLEMS…

HOW LONG SHOULD IT TAKE FOR WD TO UNDERSTAND THAT WE THE BUYERS HAS A SAYING?

SHAPE YOUR PRODUCT AFTER TROUBLESHOOTING BY YOUR CUSTOMERS IS THE WAY!

HOW LONG? REALLY? GET REAL!

WHO BECOME RICH ON WHO?

1 Like

wow, what a rant : O

I finally fixed this by giving the right permissions to /mnt/HD/HD_a2/Public

You have to use ssh to do this and I dont know why this wasnt thought out before selling this devices when any one can go in and move and delete ANY folder containing alott of TB … . 

yeah I know who cares :slight_smile: and **bleep** WD?

This is a major security flaw.   I was really hoping this would be a good solution for all of my companies work-at-home users.    I could not roll these out with that big of a risk.    I hope they fix it soon.

Puplic folder issue #1!

What I did step by step is this ( I hope this “help” is understandable for the average Joe out there )

First I used the Terminal on my Macbook, you can also use Putty for Windows. ( download Putty )

then I looked up my IP address for my NAS Server ( I have it on static IP so I know the address )

when you have the IP address for your NAS Server click on Terminal on your Mac or Putty on your Windows and connect to your NAS Server.

OS X Terminal

type in

“ssh sshd@YOUR_NAS_IP_ADDRESS”  then hit Enter, type your password and you are in.

Windows Putty

click on Putty

type in your NAS IP ADDRESS in “host name” be sure its on “SSH” and port “22”

now click on the button  “Open”

In Terminal or Putty:

if I type in “df -h“ and hit enter I can see where the “mounted” folder are located.

Filesystem                Size            Used   Available  Use%   Mounted on

%root%                     54.2M     28.8M      22.6M     56%   /

/dev/ram0                  54.2M     28.8M      22.6M     56%   /

mdev                       248.4M      32.0K    248.4M       0%   /dev

ubi0:config                 12.2M    288.0K      11.3M       2%   /usr/local/config

/dev/loop0                 92.8M      92.8M           0K    100%   /usr/local/modules

tmpfs                          1.0M           0          1.0M       0%   /mnt

tmpfs                        20.0M        1.5M      18.5M       8%   /var/log

tmpfs                      100.0M        1.7M      98.3M       2%   /tmp

/dev/sda4                944.9M    109.4M    835.5M      12%   /mnt/HD_a4

/dev/sdb4                944.9M      17.3M    927.6M        2%   /mnt/HD_b4

/dev/md1                    3.6T         1.7T        1.8T       48%   /mnt/HD/HD_a2    <——

then if I type in “ls -l /mnt/HD/HD_a2/“ I can now see the permissions.

drwxrwxrwx 4 root     root          4096  Feb 25 07:0     Nas_Prog

drwxr-xr-x   10 admin    root          4096  Mar  6 09:04    Public                   <——

-rw-r–r--    1 root     root         71680 Feb 20 16:00    groupings.db

drwx------    2 root root         16384 Feb 20 08:52    lost+found

If I am not wrong the Puplic folder was fully open for all (777), like the folder “Nas_Prog” is right now.

Now I have the “public” folder on 755 and changed the user to “admin” before that it was “root” thanks WD!..

“755” will give the “Owner” the right to write / read and execute

“Other” users will only have the right to READ and execute if they don’t know the PASSWORD for the user ADMIN!

anyway lets start changing!

this is the steps I took and I am happy with the results hope it helps others

in terminal or putty

type in

chmod 755 /mnt/HD/HD_a2/Puplic/

hit enter

now type in

chown admin:root /mnt/HD/HD_a2/Puplic/

hit enter

now you can check the folder permissions by typing

ls -l /mnt/HD/HD_a2/

the next thing I tried out was to connect my NAS without using any password, it took me in as a guest and I could read but not move or delete nor create anything! :smiley:

when I connected with my username “admin” and with PASSWORD it worked like IT SHOULD DO! :slight_smile:

NOW I am a REAL ADMIN for MY PRODUCT… :slight_smile:

thats all, hope my rambling works.

WD please react!

Implementing this isn’t that complicated but very important. 

The EX series is rather nice except many silly software issues which would not take to much effort to change. Please do it, so I can recommend this device instead of advise against it.

Well, It’s been a year and 13 days (378 days) and still the status is “In Review”. What is there to review? Clearly numerous users have stated that they do not want the Public folder / share to be wide open to everyone.

A lot of these boxes (my book live & my cloud) will be / are used in family houses where younger children and or inexperienced users could delete files.

Just my piece of mind,

  • jkindred

Just shows what energy Western Digital are using on their customers…

sickens me, really.

I agree that the lack of ability to restrict the access to the Public File is extremely worrying. I purchased this item to solve many problems and it has been successful in most. I love the product but sadly this one thing is letting the entire user experience down.

Please rectify this issue, I don’t see why voting should be the only way to get this done. If the lack of this ability (to restrict) is useful to someone out there (god knows why) then they can simply open the access to all users on their cloud!

From my experience, this is a very quick job (half a day max) and 1 unhappy customer is simply 1 too many.

Here’s more reasons for requested feature to be added in next firmware update:

  • Public share cannot be restricted, blocked or deleted - thus first drive or a RAID massive can be stuffed with unwanted data uncontrollably by anyone in the network.

  • While there is a quota setting, I’m not sure if it is appliable here.

  • And in same way data can be deleted without anyone knowing.

  • Yep, recycle bin could save from that. Up to 100Gb. So everything above that goes bye-bye. And only If the bin is on.

  • All that is also a major security flaw.

  • Were this NAS unit be put within public access network, it could be used in illegal activity.

  • NAS unit seems to respond to broadcast queries, thus can be easily found in a network. “Your software found it, so mine will too”.

  • With “Windows network” protocol not having any “off” buttons in unit settings and being “on” by default, all said above is more than possible.

  • I suppose one could turn it off via SSH, but how many people even know what that is?

And some minor but annoying reasons:

  • Public share cannot be renamed. Unexplained senseless restrictions on customer’s device = disrespect to the consumer. Bad.

  • “Shared” dirs in public share are recreated at least every boot - I never asked for this.

Public should be a default dir, that would be created after HDD initiation. But not the permament, unchangable and unrestricted one. It’s very sad that it took you more than a year, to just consider that.

1 Like

Just got an ex2100.  Couldn’t believe it.  If someone hacks my network, they can erase everything in my media folder? Good grief.  Need to be able to at least restrict to read only. 

Do not buy from WD. Just don’t. The only thing they care about is how nice their support is, despite being completly dumb and useless.

Just bumping up this “old idea / conversation”. Sorry for any unwanted notification.

Searching Google arrived to Delete Public Share Folder or Restrict Access, which after some link-clicking, I ended up here (which seems the official “Network Product Ideas” topic).

— And since I revived this old post / idea, I will use the rest of the reply for the typical “Still no fix??” comment / complain. —

The development on this platform seems too slow!

Why ~3 years have passed and no (at least) any official status has been given about this idea?
It’s like “Let’s just put a Community forum so they can solve their own problems there, save ourselves support-money, and let they dream ideas with the fake sensation that one day they will be listened”.

I imagine that they focus the efforts on their “Business level” products, but one could use the same platform / OS for all your products and just disable or limit the services/apps/functionalities/programs/daemons/whatever in each one, saving time so one can focus to the client needs.
Otherwise, I can only imagine that there is a “spaghetti code”-like development on this projects.
Crappy… looks like making and selling projects / products with a high-end marketing, with the internal quality of a entry level / Kickstarter one.

WD should focus only on the Mass Storage business instead of the Software / UX business. Outsource that to someone else, or open source it with the lead of a recognised company.

1 Like