Delete desktop shortcut of WD Discovery app

Hello,

Every time I turn on/off computer shortcut of My Home Cloud is appearing on desktop and its always on top left of the screen. If I delete shortcut and restarting computer is pop-up again.

I’ve noticed that if I exit WD Discovery application than shortcut is disappearing and when I run application its back again.

How can I delete it permanently?

are you on a Mac?

if so the shortcut is the private user space mounted as a drive. To remove it sign out of the my cloud home account in WD discovery.

I’m Windows 10 user. If i sign off from from WD Discovery than I can not access my cloud, its disappearing from explorer. Is there a way to config manually access to My Cloud without using WD Discovery?

any reply from WD team?

Hi 2DXZ !
I found this post because I had the same question and I finnally know how to make this shorcut disapper.
This shorcut reappears because everytime you shut off your computer the WD app deletes the icon, then when you log on, the WD Discovery app creates a new one on your desktop.
(Wether or not you delete the icon or try to hide it, it reaperas at every start).

So what we want to do is to remove the permission of any app to delete the icon.
So when you close WD Discovery it won’t remove it.
Then we will just hide the icon, so it won’t be visible.

right click on « Your Cloud » icon (the one you want to remove)
Click> Proprieties

Choose the « security » tab

click on « Advanced »

You’ll see a list of Users. Select « System » then click on « Edit »

Deselect all the « Basics permission » except : « Read and execute » and « Read »
(So the WD discovery App could acces to it but won’t be able to erase the file)

Now click on OK to close this window (maybe you will get an advice or something, just approve it).

Click Ok to close the other window and now you are back to the first window of « Propreties ».

Select the « General » tab.

then click on Hide.

Click ok to close the windows.

Now it should not be visible on your desktop, If you wanna see it just click on « show the hidden items ».

Ps: my english is not so good, hope you understood everything I wrote

Hi ithez,

I was trying to follow your instruction, but I’m getting lost after

“Select « System » then click on « Edit »”

Here is my screenshot how I see it

.

Ok I see the problem,
On the “Advanced Security Settings” window, click on ‘Disable Inheritance’, then click on ‘Convert permissions…’

Now the “view” option will become an “Edit” and you will be able to disable the permissions of the system on this shortcut.

Last step, when I do “Hide” > Ok. Shortcut is gone. If I restart computer, that it comes again ;(
Can you do step by step screen cast so I can follow. I’m afraid I’m doing something wrong.

I’m having the same problem. Seems like WD should fix this by now, it’s a fairly obvious problem. I still have the app running in the tray, so why do we need multiple copies of the shortcut?

I have this problem too. I’m very tired deleting this shortcut everyday. Where is wd support? Make in options chekbox - don’t make shortcut on desktop! Almost a year has passed, problem not resolved!

Edit: please delete.

New Update to My Cloud Home is coming so PLEASE add this feature to be able DELETE annoying shortcut!

Still NO solution, still NO reply from DEV team!

It is June of 2021.
After a tirade with customer support (who can’t read) and explaining this in simplest of terms, they do not have any other answer other than to shut off the Discovery app and turn off Start at windows startup and turn off notifications.
After multiple emails saying that i want the app and DO NOT WANT the shortcut to appear, they keep repeating the same old.
They do not want to fix this, they will never fix this. Denying permissions does nothing.