Delayed Write failed

Hi I am HOPING someone can help me… a few months ago, I had a power failure and began getting this error, I was simply able to unplug and replug and all my data would return. After a while this stopped happening and I believed the issue had resolved itself. Just the other day it happened again, I unplugged and replugged and again data returned. HOWEVER tonight it happened, I tried the old standard unplug and replug and NOTHING, the drive either wont show or if it does finally appear in my drive list when I click on it it is absolutely blank and no amount of unplugging, replugging or rebooting my entire system is changing this.

I absolutely can NOT reformat and lose data, it has photos, including of my father who died last year, videos, program data, and back up of entire websites on it. SOMEONE PLEASE HELP. I have to recover the data.

Perform a file-system integrity check on the drive, if possible. could be that.

Have you tried to use the drive in another computer? It might be your computer that’s at fault. Try another computer to eliminate the fault. Also try another USB cable. Hopefully it’s not the USB socket on the drive.

Some external drives have a USB to SATA bridge in the case so it could be possible to open the case, remove the bridge and connect the drive directly to a computer’s SATA connector to access the drive. Maybe the USB to SATA bridge could have gone faulty? I know that some Western Digital drives have a custom PCB where the only option is to connect the drive to a USB port. If that’s the case then it’s a trouble-shooting option is not available.

Failing all of that, you may have to use the services of a specialist data recovery organisation who would take the drive apart to a view to extract the data on the drive and put it all on a replacement drive or other media.

I actually tried it on a laptop at home and nothing, however I took it to work today and everything was there. I used the safely remove software, brought it home and plugged it back in, again the drive shows but when clicking on it, it shows nothing there. How can I fix this I need to be able to access the external.