Deezer stopped playing

I have been using Deezer for some time but i went to play a playlist today and it won’t play. When I select  a track to play the WDTV just skips through all the tracks on the playlist without actually playing anything. Once it gets to the end of the playlist its says:

‘unable to play the selected file. Please see the user manual for a list of supported file formats.’ 

I have not changed anything on the playlist and have never had an issue playing it before. I checked on my laptop and it plays fine so it is just the WDTV. Does anyone knw the solution here, I have ditched all my other music files and only use Deezer so now I am without music.


Hi, press the reset button on the bottom side for 1 second.

1 Like


I own a WDTV Live HD gen 2. Deezer has stopped working on my system as well. I am getting the exact same problem as you. I tried the new FW but that didn’t fix it.

Tried the reset, no luck unfortunately

Hi, I seem to have got mine working. I’m not sure if it’s my ISP or not. What I did was changed a setting in my Modem/Router, I unchecked obtain DNS automaticaly and I used Google’s DNS address which is and /

I noticed now its being routed to Paris instead of Asia.

1 Like

thankyou, took me a while to work out what you meant and how to do it as i am not that savvy but I did it and it worked :smiley:

Hi everybody,

I’m new to the community, I played a lot with my WDTV and it’s very cool. I wanted to listen to Deezer but I got the same problem of song switching one after another without playing. I tried to change my DNS but it didn’t worked. Is there another solution ?

Thank you