Deezer Login (FW 1.04.10_V)

Just loaded the new firmware and I’m absolutely loving it. Also surprised to find a new music service, Deezer.

I signed up with a new account on the Deezer home page (didn’t link with Face Book). When I try to Sign In to Deezer from the WD TV Live menu, I’m left with a spinning wheel which never times out or logs in. Am I doing something wrong, or is this a bug? Has anybody else had this problem?

make sure you enter the email address of your account, not the username.

once signed in, your playlist might come up empty

if so, you need to click on the sign in-> your account again to see your saved playlists

Thanks shavanni.

I am signing in with my email address. I created a second Deezer account using a different email address to see if it had something to do with the first account. Tried Signing In with the email address on the second account and I still get the spinning wheel. No timeout. No login.

Sorry i couldnt help

i had the same problem but i was because i entered the username, not the email.

not sure what else u can do, factory reset perhaps?

Shavanni was correct.

For whatever reason, I needed to reset to factory defaults. Once I did that, I was able to sign in to Deezer.

If you have any problem particularly after a firmware update its advisable to reset to factory defaults.