Dead WD MyBook Essential 2TB USB 3.0 WD20EARS-22MVWB0

I did not drop it x)

I was writing data on it and all of a sudden the process failed and the drive dissappeared.I can’t see it on My Computer/Disk Management.

I took it out from enclosure(warranty was over anyways) and I plugged the drive directly to desktop motherboard via SATA cable and BIOS detected the drive but reported as 0 MB.

Then I booted into operating system but My Computer / Disk Management did not detect it.

Then I used a SATA-to-USB adapter so instead of directly connecting to motherboard’s SATA , I connected to USB port.This way My Computer does not see the drive BUT Disk Management console sees the drive as “Not Initialized”(capacity 0MB).It does see the correct drive model name which is WD20EARS-22MVWB0.

When I use the SATA-to-USB converter to plug the drive to computer, the drive spins for about 40 seconds then it stops ,only AFTER it stops I can see the drive in Disk Management (as non-initialized drive).The computer will not recognize the drive while it’s spinning.

So, after the drive stops spinning the drive appears in Disk Management.I right click on it and click “Initialize”.It asks me if I want to use MBR,I choose YES and click OK and it tells me “Data Error:Cyclic Redundancy Check”.I assume since the drive is not spinning the initialization can not be done.

I checked the PCB board and there is nothing fried(both sides) but someone suggested me that a firmware could be corrupted.Another thing I want to mention is that the drive produces clicking sounds before it stops spinning.

I also tried SpinRite program but the drive makes clicks and it stops and SpinRite can’t recognize the disk.I used a software TestDisk and it DOES see the disk but it failes to read it.

I tried using the drive in Linux and Windows XP mode with no luck.

I tried Kaspersky Rescue Disk with no luck.

I used another bootable software called PartedMagic and it does see the drive and correct model but only after the drive stops spinning ,so it’s like Windows 7.

I tried pretty much every software in Hirent’s Boot CD.

The strange thing is when I use enclosure kit and the original USB 3.0 cable, the Disk Management won’t see it but when I use SATA-to-USB adapter it does see it.

When I use SATA-to-USB adapter I do COMPLETELY bypass the enclosure so that is not the root of problem.

I’ve only written about 300GB data on it during its lifetime.This was suppose to be my backup drive but I had files on it that I don’t have anywahere else lol

Any ideas on how to recover data without paying $2000 to professionals ? That is how much will cost recovering 2TB drive I beleive.

Let me know if you need any screenshot pictures or photos.

Hi, you can try recuva or testdisk to recover your files, but if the hard drive is not recognized you need to contact a professional data recovery company. 

1 Like

TestDisk sees the drive and recognizes the correct model name and actully recognizes the correct size(not 0mb) but how can i recover files using that software? And also,do I have to make a bootable CD using Recuva or is it an executable installer in operating system environment? Thanks.

I have had the exact same issue – were you able to recover anything?


I was asked to pay at least $600 by a professional data recovery agency in order to save my files but they weren’t worth that much money so I threw the hard drive away after scratching and destroying it.

Before doing it, I diassambled the hard drive to see what’s inside and I plugged it in while it was ON so I could see the platters spin the the eye read data but it was moving back and forward and making click sound.The strange thing is that when I played with the header with a screwdriver and hit it really hard ,the PC all of a sudden recognized the drive and its correct 2TB size and it allowed me to “Initialize” the drive from Disk Management console in Windows 7.I tried to Initialize it so it could show up in My Computer folder but the process never finished so I got mad and hit it one more time with a screwdriver and this time I totally damaged it lol

Now it’s gone forever…and ever.


There is only a 5% possibility that the problem is caused by faulty PCB board.Prior to this,I sent my drive to a company and they replaced the PCB and re-soldered the BIOS chip but the drive still didn’t work.

95% of a time the clicking hard drive has a problem with the reading head so the only way you can get data out of it is by sending it to professional recovery center where they can take out platters,put them inside another drive and read data out of it (all needs to be done in a surgery-style clean room with professional tools ).

Your description is exactly what is happening with my drive. It seems strange that the head would be bad yet output that garbage in the wd tools. I tried the western digital lifeguard tools and that sees the drive and serial # as a bunch of garbage characters.

I am sending it to a nearby place in Los Angeles (Ventura) that does hardware/firmware recovery techniques for HDDs up to but not including Cleanroom head replacement for $300… Best part, no fix no pay.

Wish me luck.

If that doesn’t work I might try a head swap myself… Nothing to lose and only something to learn.

I’m sure they will be able to recover almost all of your data.

If you have lots of videos then they migh be corrupt though.I suggest you stop doing anything with the drive, don’t even plug it to computer anymore because it will make things worse.

Also, be careful with the pricing.Some data recovery companies advertise $300 initial fee but they charge extra money for large hard drives(such as my 2TB drive) so ask them about it before doing business with them.

I wish you good luck.


if you decide to play with the header with a screwdriver, don’t touch the front part of the header.I was “playing” with the back side of the header, the area where it touches the magnet.

I probably wasn’t very clear in my last reply. what I meant to say was that this company does everything except for open the drive up. so they will do everything to the drive to fix it including changing the firmware, using donor PCB boards flashing BIOS – anything without having to actually do clean room type of activities. they’re very clear about their pricing it’s 300 dollars and if they can’t recover the info from the drive there is no charge and they return the drive to you in the same condition that you gave it to them. There is a $100 surcharge on drives over 2tb (if they can recover it).

from their hundreds of positive Yelp reviews I am willing to at least give it a shot.

Like I said, its worth a shot… If it works out, ill post their link and my experience. If not… Ill still post what happened.