Dead WD My Cloud 4T

My WD My Cloud 4T suddenly went dead… RED light (steady) and I red in this forum couple of guides to make him alive again, but still can’t find an image to use… all the links here are expired.

I suspected that the firmware of the driver board is corrupted (most probably happened during autoupdate as it did not happen in front of me.

I used a board from another (new 2016) version 4T My Cloud, but it did not recognize the hard disk and started blue light then red light (both are blinking).

Tried the expected faulty board on the new driver and of course it did not work.

Wanted to be sure that the old hard disk is not faulty, and to do so, I removed all the partitions :frowning: I did not really care about the data but seems also that now I have to figure out how to re-create the partitions from an image)

So, my questions if someone can help on this:
(1) Is there is a way to fix the board firmware problem
(2) As I can’t find an image to download, what is the procedure to create an image from my new WD My Cloud in order to use it on my old drive (I know, I will still have a problem to fix the board, but I will work on this later)



Try swapping the disk drives between the two My Clouds. If the disk is bad then the other
My Cloud will get the red light and the old one should work.


Actually I did… Even though neither combination worked, I guess the reason is that the firmware board and the OS in both are different. one belongs to 2014 and the other to 2016

I am pretty sure now that the Hard Disk is PHYSICALLY OK, but need to put the appropriate OS on it

Gen1 h/w vs Gen2 h/w.

You may have to search through all the ‘unbricking’ posts.

Do you need to recover data? There’s a thread on that today.

You are right… the first is firmware 0.4xx and the second is 2.xx

No, I do not need to recover the data, I already searched on the posts and there are lots of valuable information, really… unfortunately all the links to download WD images are outdated and not working.