Dead 2tb MY Cloud

Hi I have a 2TB MY Cloud that went totally dead. No power, nothing. I bought a new power plug in case that was the problem but make no difference.

I have managed to take the drive out of the case, and plugged into another machine via a one of those USB drive caddy.

I have tried on Mac / Windows - but it cannot access the drive. On Mac I just see a 100mb partation thats it.

Are these drives encrypted or use some sort of special disk format? if the case is dead, how are you meant to recover ? I assumed it would have been formatted as FAT? or ExFat?



Not sure which format it’s in off the top of my head, but it’s a linux filesystem - EXT3 or EXT4 I think…

Yeh just found MacFuse which can mount Ext4 - i can now see the Ext4 partations but still wont mount :frowning:

Use a flavor of Linux like Ubuntu to access the drive. You can use a Linux boot disc with your Windows computer to boot right into Linux to view the drive. There should be a total of 8 partitions on the drive with partition #4 (example: sda4) being the data storage location for the “shares”. It is in ext4 format.

If the drive spins up and is accessible in another PC then that points to either the power supply for the My Cloud being dead or the NAS circuit board the hard drive was attached to within the My Cloud enclosure being bad.

1 Like

@Bennor Thank you! Created an Ubuntu install in Parallels on my Mac, only issue i had was that the folder on drive was locked as I was not the owner so did a sudo chown -r and then i could access. Currently backing up to another drive.

1 Like

Glad it worked and you were able to get your data off the drive. I assume that the locked folder was a folder that was set to Private within the Dashboard at some point.