DataVolume doesn't exist after firmware upgrade to 2.2.91 and NO SSH option either?

I happened to be setting up some automated backups and then went to my ShareSpace configuration and found there was an upgraded firmware - which I let it do automatically.  Went up to 2.2.91 and then after it restarted I started by not being able to mount the drive.  I go back into the configuration and find the DataVolume doesn’t exist message…  So in looking through these forums I see there’s a slight hope if SSH can be enabled…

I don’t see SSH as an option anywhere.  I’ve tried Advanced->Network->Services but I only have:

UPnP

Web Access: HTTP/HTTPS

FTP:

NFS:

No SSH?  Where is it???

Any other suggestions for me???

The main menu after logging in is set to basic mode (Upper right); Click on Advanced Mode then

Go to System>Advanced. That’s where it is.

I have a similar problem except I can use Discovery to turn LED On or Off but cannot configure the NAS.

If you are referring to the blue LED it’s in the same menu as the ssh flag in my previous response

many thks, yes its the blue LED but other than turning it on or off Discovery does not appear to see the the Sharespace.

Within System->Advanced all I have is :

System Identification:

Certificate:

Extend Span:

Power Saving:

NOTHING about SSH…

Odd… as it is the first item on mine  in that list you just posted (I’m at 2.2.91). If you upgraded from a release prior to when ssh was enabled, you may have not gotten a completed upgrade which would account for it missing in that menu. Mayne that’s why you don’t see the shares. You might try powering off and restarting.

Sharespace is based on Linux and the upgrades have to work 100% or it can be unstable (which sounds a bit like the state you are in). The shrespace “firmware” is not like what I know as firmaware. It’s a subset of the Linux operating environment and there are literally thousands of files on the device. Even an upgrade with a smaller set of files (possibly including a kernel upgrade) needs to go right or you can have a mixed environment of older and newer files.

The firmware upgrade supposedly succeeded – bolded line below in the logs (and it claims there is no update available).  Last line before I rebooted it was that the itunes server couldn’t find the data volume…  After further reboots I always get this kind of message after a few more minutes:

  12/29 22:17:18  WDShareSpace daemon.alert wixEvent[884]: Volume Status - Volume ‘DataVolume’ doesn’t exist.

I agree firmware upgrades HAVE to be successful for me to trust this thing…  and now I don’t trust it…  I posted in the main “DataVolume doesn’t exist” thread as well…  I think I’m going to have to go with a data recovery place - cause WD just wants to send me replacement drives…

Logs after my successful firmware upgrade:

 12/29 21:32:17  WDShareSpace daemon.warn wixEvent[1339]: iTunes Server - iTunes server cannot find the path to /Public/Shared Music. Please verify that the folder name has not been changed.
 12/29 21:32:05  WDShareSpace syslog.info miocrawler: === Walking directory done.
 12/29 21:32:05  WDShareSpace syslog.info miocrawler: === mc_trans_updater_init() …Done.
 12/29 21:32:05  WDShareSpace syslog.info miocrawler: mc_trans_updater_init() …
 12/29 21:32:05  WDShareSpace syslog.info miocrawler: === inotify init done.
 12/29 21:32:05  WDShareSpace syslog.info miocrawler: === mcUtilsInit() Done.
 12/29 21:32:05  WDShareSpace syslog.info miocrawler: mcUtilsInit() Creating free queue pool
 12/29 21:32:05  WDShareSpace syslog.info miocrawler: === mc_db_init …Done.
 12/29 21:31:59  WDShareSpace daemon.info wixEvent[1339]: System Startup - System startup.
 12/29 21:31:48  WDShareSpace syslog.info miocrawler: ****** database does not exist. ret = -1, creating path
 12/29 21:31:48  WDShareSpace syslog.info miocrawler: mc_db_init …
 12/29 21:31:48  WDShareSpace syslog.info miocrawler: +++++++++++++++ START OF ./miocrawler at 2010:12:29 - 21:31:48 [Version 01.09.01.2] ++++++++++++++
 12/29 21:31:41  WDShareSpace daemon.info wixEvent[1339]: Network IP Address - NIC 1 got IP address 192.168.0.131 from DHCP server.

 12/29 21:31:41  WDShareSpace daemon.info wixEvent[1339]: Firmware Update - Firmware update succeeded, new version : 2.02.91
 12/29 21:31:41  WDShareSpace daemon.info wixEvent[1339]: Network Link - NIC 1 link is up 1000 Mbps full duplex.
 12/29 21:31:32  WDShareSpace daemon.warn wixEvent[1339]: Network Link - NIC 1 link is down.
 12/29 21:31:31  WDShareSpace daemon.info wixEvent[1339]: UPS Connected - Communications restored with UPS.
 12/29 21:31:29  WDShareSpace daemon.info wixEvent[1339]: HDD Status - HDD 1 is found.
 12/29 21:31:24  WDShareSpace daemon.info wixEvent[1339]: HDD Status - HDD 2 is found.
 12/29 21:31:18  WDShareSpace daemon.info wixEvent[1339]: HDD Status - HDD 3 is found.
 12/29 21:31:18  WDShareSpace daemon.info apcupsd[1748]: NIS server startup succeeded
 12/29 21:31:17  WDShareSpace daemon.warn apcupsd[1253]: apcupsd 3.12.2 (18 January 2006) redhat startup succeeded
 12/29 21:31:10  WDShareSpace daemon.info wixEvent[1339]: HDD Status - HDD 4 is found.
 12/29 21:31:06  WDShareSpace syslog.info syslogd started: BusyBox v1.1.1
 12/29 21:29:39  WDShareSpace syslog.info System log daemon exiting.
 12/29 21:29:37  WDShareSpace daemon.warn apcupsd[795]: apcupsd shutdown succeeded
 12/29 21:29:37  WDShareSpace daemon.warn wixEvent[884]: System Reboot - System will reboot.
 12/29 21:29:37  WDShareSpace daemon.warn apcupsd[795]: apcupsd exiting, signal 15

Well, while it claimed the upgrade was done, it doesn’t seem so.  The DB it’s complaining about not being found I believe  is located here:

/DataVolume/jewab/transcodingdb/miocrawler.db

-rw-r–r--    1 root     root         4096 Dec 14 09:45 miocrawler.db

However in doing an examination of the Linux program miocrawler (using the tool “strings”), it is looking for this.

** mc_db_search_del_cb(): failed malloc %s
/CacheVolume/transcodingdb/miocrawler.db
SQL error: %s
set mdate = %ld  
where timestamp != %ld
++++++++ database exists: ret = %d
=== mc_db_init …%s
****** database does not exist. ret = %d, creating path
create table Status (mdate INTEGER, desc CHAR(80), etype INTEGER, mc_version CHAR(16), db_size INTEGER )

/DataVolume/jewab/transcodingdb $ ls -al
drwxr–r--    2 root     root         4096 Dec 14 09:45 .
drwxrwxrwt    9 root     root         4096 Dec 24 15:28 …
-rw-r–r--    1 root     root         4096 Dec 14 09:45 miocrawler.db

but if you can’t ssh in, then you can troubleshoot any further.

I meant to say you “can’t” troubleshoot further.

I tried pulling out 1 drive at a time and restarting the NAS to see if there was a problem with a single drive that would then allow the data to be accessed - but that did not help at all.

I finally had to go through a data recovery service to recover my RAID.  They seem to have recovered everything - but a few scattered files that were new within a few hours of the RAID failing with the DataVolume doesn’t exist message.  This doesn’t make much sense to me because there were some new files before and after the ones that are missing - that actually do exist in the recovered version…  Because of the few recent files that I know did not get recovered - I’m a little concerned that I might find some older data that is corrupt or not all there… 

This occurred apparently in conjunction with my firmware upgrade to 2.2.91 - that also appears to have failed (since I do not have the SSH option available).   So like you said - without the SSH option - I did NOT have a reasonable shot to get to a linux prompt and attempt any diagnosis/recovery on my own…

All I have to say is - GOOD BYE WESTERN DIGITAL!  This experience with their support staff has been miserable.  I’ve had enough.  Maybe I will say hello to Synology…