Data Lifeguard Diagnostic for DOS – Working OS but “NO DRIVE FOUND”


#1

System:

Motherboard: ASUS P5Q-Pro (BIOS 2102)

HDD: WD1002FAEX (running at AHCI using the Intel HDD-controller)

OS: Win7 SP1

Problem:

The “WD1002FAEX” (and two other WD-disks) are not detected when running “Data Lifeguard Diagnostic for DOS” (the ISO-file was burned to a CD from where the application was running during the test).
Error message:

NO DRIVE FOUND

ERROR/STATUS CODE: 0120

According to WD ‘s Diagnostic Error Codes:

(Error code: 120 - Explanation: Unknown Error): “An unknown error has occurred during testing. This may be an anomaly. Check connections and retest. If the error repeats, replace the drive.”

This is nonsense. All the drives are detected in the Setup, they are all working, the OS is installed at the WD1002FAEX and all discs have been tested an passed in the Windows version of the diagnostic software – and even tested with the DOS version on another motherboard (Gigabyte P35-DS4) – and there the “Data Lifeguard Diagnostic for DOS” had no problem detecting the discs (using exactly the same cables).

This issue was posted earlier in this forum but there problem was never solved:  Desktop/Data-Lifeguard-Diagnostic-DOS-major-issue 

So the issue seems to be with the ASUS board. But only when using the DOS version of “Data Lifeguard Diagnostic”.

Even when using other HDD diagnostic tools all tests are passed in the ASUS platform setup.  

The Question:

Why isn’t the Data Lifeguard Diagnostic for DOS working as it should when in use at the ASUS P5Q-Pro?

Could it have anything to do with the AHCI?

Kind regards


#2

Most of the users don’t have the same setup that you have

I checked the thread you suggested and one user recommended IDE CD

you can try contacting WD support to see if any correlation with the ASUS board


#3

- UPDATE -


I Changed settings in BIOS from AHCI to IDE.

Now I got this message instead:

Unable to locate the License Agreement file, DLGLICE.TXT

Please make sure that the License Agreement file is located in the same path as “DLGDIAG.EXE”

When in DOS looking in to what’s on the CD (Volume A) I found: 

  1. 7 files of which:
  2. Three are COME-files (IMBBIO, IMBDOS, COMMAND) 
  3. And one BAT-file (AUTOEXEC).
  4. Two were TXT-files of which one was the “DLGLICE.TXT”  (the other one is “DLGDIAG.TXT”
  5. There were one exe-file and it wasn’t named “DLGDIAG.EXE” , but “DLGDIAG5.EXE”

So what is going on here?

The file that is declared to be missing in the new error message is actually NOT MISSING at all.

But the EXE-file that is presumed to be there, that one ISN’T THERE (or is not correctly named in the software)!

Test with Gigabyte P35-DS4 motherboard

So I tested once again at the Gigabyte P35-DS4-System.

Everything worked OK.

Back to the ASUS board.

And now I change to a brand new cable for the DVD-RW hardware.

BIOS set to AHCI.

Result:

The same error code as earlier: (“NO DRIVE FOUND ERROR/STATUS 0120”).  

The directory of A is of course the same 7 files.

AND: Trying to change directory from A: to any of the HDD onboard is not possible

BIOS set to IDE

Result:

The same result as earlier (“Unable to locate the License Agreement file…”)

AND: Trying to change directory from A: to any of the HDD onboard is not possible (for a second the prompt accepts the command C:, but a half second later, as always, you end up at A:)

Ok. Now exchange of the DVD-RW hardware (I used the one that worked fine with the Gigabyte P35-DS4).

BIOS set to IDE

Result:

The same result as earlier (“Unable to locate the License Agreement file…” and unable to change directory)

Last test, changing the SATA connection contact on the motherboard for the DVD-RW hardware:

Result:

Almost the same.

First the error message from before (“Unable to locate the License Agreement file…”)

Then:

Cannot load the file A:\COMMAND.COM

I_nsert correct disk and Strike any key_” – a message that is repeated over and over again with about 30-60 seconds interval.

(We are talking about the same disc that a few minutes ago were working absolutely correctly in the Gigabyte P35-DS4 system.)

After that message there is no access to the prompt .

The only way out of this situation is to eject the CD and shut down the system.

I checked the CD for the files that was said missing – they were all there.

So, obviously, the CD do have the necessary files to execute the test. But only if not in use whith the ASUS P5Q-Pro System.

The question:

Is it the WD software that is unable to work with the P5Q-PRO - or is it the ASUS board that, for some reason, is not working with the WD DOS software?

There is the difference in behavior using AHCI or IDE in the Setup that makes you wonder…

Could any knowledgeable ASUS tech expert give some good explanation to why - and a working solution to this, as far as I could see, unreliably and badly working WD software - or if it is the ASUS P5Q-Pro motherboard?

KR