Dashboard will not load

Dashboard will not load. Firmware updated already through dashboard before I could not log on. Just bought yesterday. No update in Quick view.  Any suggestions? If not will be returning as support from WD so far is very poor.

If it’s not been used with the upgrade brigning a brand new MyBook Live (WDTony, you reading this?) then it would be better to RMA the drive or take it back to the store for a replacement or your money back.

It is unacceptible that a brand new out-of-the-box MBL has got bricked by a firmware upgrade.

Yesterday i bought an MBL, set it up and immediately installed the latest firmware. The download and install was reported as successful but when it rebooted, the dashboard wouldn’t load anything apart from the background image. No text, no other images, just the background.

Today i returned it to the store and got a replacement. After upgrading the firmware on the new one, i’ve now got the exact same problem.

You’ve got a bug in the firmware guys. Sort it out and tell us how to install the new firmware without the use of the dashboard or tomorrow when i return this unit, it wont be for a replacement WD drive.


I have 2TB MLB. installed software and mapped the drive.

It won’t open up the dashboard so can’t adminisiter the drive. Tried uninstalling and reinstalling still made no difference, just hangs.

I dont think this is a browser issue, I have tried diffrent browsers. I have tired installing on a differnt PC.

Are there any settings I need to enable/disable on the browser or Router e.g. ports or proxies.

I can access the mapped drive OK, and copy files To and from the MLB using windows explorer and also can access the twonky server



I have the same issue.  Not sure when it happened, but first noticed when I could no longer connect from My IPhone to my photos using WD Photo app.  I also can still access drive using explorer, but need my dashboard back.  Losing confidence quickly as there has been little to NO response in addressing the issue.

Having same issue, and then some.  My mBL says that the page is under maintonence, try again later, this has been going on for over a day.  And when I try to access from WD2go, it says that my MBL is offline, but I can still copy and move files to it.  And to top it off, I think it is crashing my router and IP address.  Because it seem to take me offline after the update and when I mapped my MBL through the computer section.  Suggestions, thoughts?  Is there anyway to revert back to previous firnware?  Otherwise guess I will go exchange it, and not upgrade.