Dashboard version 3.5.2.7 does not start - how to download v3.4 StandAlone?

Hi, I recently updated my Dashboard from 3.4.2.8 to 3.5.2.7 and it stopped working. It just displays “Loading” message and then stops immediately.

Is there a way to fix it? If not, where can I download an offline installer (stand alone) version of 3.4 from?

Thanks in advance for your help.

Thank you, but it does not work. FileHorse offers only 4 MB online installer - it means that it downloads the latest available files, in this case it is v3.5.
I need a link to DashboardSetupSA.exe which size is 300+ MB :slight_smile:

Yes, agreed. sorry to waste your time

1 Like

There is another thread on this - 3.5.2.7 is broken for us as well. Similar behavior - opens, begins to load and then just vanishes. There was a corresponding error in the Event Viewer on our PCs indicating some type of memory access error.

I too have been searching for the dashboard 3.4 download and haven’t had any luck.

1 Like

I was looking for any existing thread, but haven’t noticed it - sorry :slight_smile:

So, we have to wait for another upgrade and hopefully it will work. Thanks for your message!

Western Digital is a very reputable company, but this Dashboard 3.5.2.7 failure must be addressed and communicated to all of its customers. I would ask WD to communicate the current status of these repairs. Please do not just blow off your customers. Please communicate!

Please communicate your current issues with Dashboard 3.5.2.7. How are you going to resolve this failure, and what are your plans to communicate the resolution to your customers?

Holly ■■■■, am I so pissed off with the incompetence that large companies exhibit, This is a simple fix. Again, WD is a very reputable company, but right now they are just being lazy and incompetent.

WD, you need to purge your company of dead wood.

Hi All

WD_BLACK SN850 2tb, Windows 11 Pro

I’m going through this also, only had the Drive since Yesterday, Installed all ok and working as should apart from the DASHBOARD, so i got intouch with Western Digital Customer Service and Support
https://www.westerndigital.com/support and they have been trying to pinpoint the issue, but they asked me to do send them a log file of what happens when you try and start the DASHBOARD, this is how to get a log file, just sent it to them and might help solve whats going on

Hello Andy,

Thank you for your understanding.

I would like to share with you a solution from concerned team about this issue. Is it possible to try below steps?

  • Right click the shortcut and click Properties.

  • Change the ‘Target’ : to show " -debug" to the end of the target.

  • It should look like this: “C:\Program Files (x86)\Western Digital\SSD Dashboard\Dashboard.exe” -debug

  • Then try to load the dashboard again.

  • After loading the Dashboard, please open the Dashboard file.

  • Collect the logs that are created in the Dashboard install directory “dashboard.log / dashboard2.log” and send them to us for investigation.

  • If you couldn’t see ‘dashboard2.log’ it doesn’t matter you can send ‘dashboard.log’ also.

We will continue to investigate this issue with the Logs which you will send to us.

Hope it Helps

1 Like

Not working for me either same issue

Same here, also tried the Standalone download, same results.
only other “help” is event id: 1000 (application error, faulting app = dashboard.exe) logged in windows event log. My system is Win 10 64 bit, all up to date. no other issues. Just tried the debug tip, had a look at the log, " Critical, chroma connection failed, file not found" whatever that is its not good ! Ran system restore, got dashboard 3.4.2.9 back and working. Will ignore WD “update available” in future !.

Please, WD is a multi-Billion dollar company and they have the people and the resources to resolve this issue.
The WD Dashboard is a very good selling point for all their SSD’s. Imagine if you bought your first WD SSD and you find the Dashboard is dysfunctional. Dysfunctional for weeks not days, I would lose confidence in all WD products. Maybe Sea Gate or Kingston can do a better job?

Senior management needs to investigate this “weeks” long issue and purge the department of individuals who lack the motivation to resolve this issue. As a retired senior manager in the produce industry, I would have been on this important customer issue immediately, and a resolution would have happened in days not weeks.

Hi All
Got a Reply back from Support and they told me to do this,
There is a link to the Old Dashboard and it worked for me, it might work for some of you.
It did update my Firmware to the latest Version and seems to work Great

Hello Andy,

Thank you for your reply.

Please try to uninstall the WD Dashboard version, reboot your pc and install an older version from:

https://wdc.box.com/s/6wzhqc0wddqiz3w8odmsmi154nxlfsye

If you have any further questions, please reply to this email and we will be happy to assist you further.

1 Like

Hi R1-Mini,

thank you so much for sharing the link. This solution works for me as well and v3.4 runs smoothly. But if I tried to update to v3.5 from this version, it failed as previously.

So, I have to stay with v3.4 for some time.

Yes same thing happened to me so sticking with the same version as you

Tried the link, got “link has been removed or is unavailable to you” message back ! Was only going to use it so i had a backup file, will have to rely on system restore for any future problems. Maybe - one day WD - will get its act together, don’t hold your breath !

Same here… this is extremely disappointing. Why would WD not just make that link available for everyone in this thread? Unbelievable…

Edit: Found a link https://file.io/5aIMnLQwrTTZ enjoy. Don’t upgrade until they release a new version.

Same problem but all of the above links no longer exist. I tried to download earlier versions of Dashboard…but apparently the installer on File horse uses the newest version.

Error log:

Mon Apr 18 16:22:03 2022 0x126b1c8 Critical: – js: “Chroma connection FAILED FILE_NOT_FOUND”
Mon Apr 18 16:22:03 2022 0x126b1c8 Critical: – js: “Uncaught (in promise) #”
Mon Apr 18 16:22:03 2022 0x12f03b8 Warning: – Failed to download disables and quirks for “WDC WDS500G2B0A-00SM50” “X61130WD” “inbox”

99% sure wd has someone pulling these off the file hosts. I’ll find one that works.

Got it. Will give it a try. Thx