Dashboard say HD has 0KB free and keep content scanning


I am about to give up on this device that I had for a couple of years. I have a my cloud 3 TB with a 1 TB back up HD for the Back up files.

I have a Widows 10 laptop. the cloud is properly hooked up to the wireless modem. while trying to do a back up of the files on the cloud it stopped working ( tired many time to set up the automatic back up…it never worked), I manage to reconnect to it but the dashboard keeps in saying that the HD is at 0 free space and the content scan is on constant scanning mode, the firmware is v04.05.00-315.
I have tried many 40 second reset to try to get back to all of my files ( as I was not able to do a back up I may have lost all of my files…and I hope not)

I find this very hard to comprehend how this work, I have tried to map the HD ( from reading the post on this site) but my computer says that he cannot find the HD( cloud).

Please, I am not a computer wiz, I have had computer for many years and even built some years ago as a hobby, so please keep that in mind while responding to this call for help. I hope that the solution is simple and that you can help me.

thanks in advance for your reply.

It is not clear what you are attempting to backup and to where. Are you trying to backup the My Cloud to a USB drive attached to the My Cloud? Or are you trying to backup a computer to the My Cloud? What are you using as the backup program or app?

Are you using WD Sync by any chance? There is a problem with WD Sync where it can quickly fill the My Cloud hard drive with hidden files causing the unit to run out of free space.

A 40 second reset should not remove any user data. A 40 second reset just resets the various My Cloud Dashboard settings to their default settings.

If backup the My Cloud (using Safepoint) to a USB drive attached to the My Cloud you will need to ensure the USB drive is large enough to hold the data stored on the My Cloud. For example if you have more than 1TB stored on the My Cloud and attempt to backup using Safepoint to a USB drive you may get an error because the USB drive does not have enough space to store the data being backed up.


thanks a lot for your reply to my call for help. at this time I am not trying to do a back up as I am not able to connect to the MyCloud.

as mentioned above, on the dashboard the information showing is that the HD has 0 KB of free space and that the content scan was always showing “scanning”.

I was able with the help of the WD support to have the content scanning to show “Idle”. we tried to rebuilt the database using the “setting-general-cloud access-configure and rebuilt database” with no success.

I received an e-Mail today from WD support advising me that the My Cloud had most likely failed and to look for some help in recovering the data from an outsource. I believe I had this device for about 3 years, it never worked properly, I constantly had to reboot it and it never did the automated safepoint ( as I was not able to get that to work I do not have a safe point to do a recovery from). I am not sure what to do from here, try more or gor for outsource to try recevering the data.

Any suggestion would be welcome.


You may be able to recover the data yourself. See this thread:

1 Like

Hello Mr Paranoia,

been reading this post you suggested and it look like it is worth a try, i took the HD out of the enclosure and the HD is spinning and I can hear the “arm” ticking on the disk inside. I beveive that it might still be working. I will get a SATA to USB wire tomorrow and follow the instruction mentioned in the post.

I will update of my progress in the next day or so.