Dashboard page blank

I was unsure as to whether to buy this product due to the large number of negative reviews. I took the punt. Sadly, it seems that made a mistake.

After unpacking the drive, I was able to set it up without any issue whatsoever. Everything was going smoothly for 24 hours, I was able to create shares, access the dashboard, copy files etc. . Today, 24 hours after opening the box, I tried to access the dashboard. This is what I see:

Here are the ‘fixes’ I have tried:

  • Cleared cookies, cache, flushed DNS etc.

  • Tried multiple browsers on multiple computers

  • Accessed the dashboard using the IP address (same result)

  • Reset by pulling the plug and plugging back in

  • Reset by using the paperclip on the reset button on the back (held for 10 seconds)

  • Reset by using the paperclip on the reset button on the back (held for 40 seconds as per WD site instructions)

  • Re-installed WD Getting Started software on two separate computers

  • Editing the dashboard rendered HTML in order to see the Setting menu. After doing this, I could access the settings and attempted every type of restore that is listed in the settings menu, but nothing worked - each time they locked up after being left for a few hours at a time.

If God is hovering around these forums, help would be appreciated.

To anyone who is successfully using this product, you don’t know how lucky you are.

To the makers of this product, you are a disgrace. It is a piece of junk. The reviews were right, and I was wrong.

Might be a bad harddrive.  RMA or return it.

Amazon refunded me (including international shipping - go Amazon!).